Beryl Multiple SSID

Hi,

I’ve just bought a new GL-MT1300 and trying to create several SSID on single wifi chip (e.g. 2.4 ghz).
LEDE does only allow to have one master and one guest network but I would like to have some more ssid and combine it with vlans.

I’ve tried to create additional ssid from luci but this seams to break lede (I believe due to not compatible mtk drivers), so I have to reset the router to bring it back to normal.

So my question is, is there a way to create more SSID (potentially from command line)?

Do we have any other restrictions due to mtk drivers in luci? Especially can I use firewall, vlans etc?

If so what router would you suggest that doesn’t have these problems? Is opal any better?

Thanks

You can check /etc/config/wireless about how the guest wifi is configured. This is exactly what you needed. Just duplicate the guest wifi config and create a 3rd interface.

Do not use Luci as it is not compatible.

1 Like

I’ve tried your solution.

After duplicating the guest config and giving it a different wifi-iface name. I can see an additional guest network in lede gui, but if I activate this new interface in through lede, the gui is showing me that it should be working but it is not found by any device.

Pls post your config. Pls note you need a differnt ifname.

Here my config

config wifi-device 'mt7615e5'
	option type 'mtk'
	option hwmode '11ac'
	option htmode 'VHT80'
	option band '5G'
	option txpower '20'
	option noscan '1'
	option region '10'
	option cfg '/etc/wireless/mt7615_5g.dat'
	option channel '40'

config wifi-iface 'wifi5g'
	option device 'mt7615e5'
	option network 'lan'
	option mode 'ap'
	option disassoc_low_ack '0'
	option ifname 'ra0'
	option wds '1'
	option key 'goodlife'
	option encryption 'sae-mixed'
	option ssid '5G'

config wifi-device 'mt7615e2'
	option type 'mtk'
	option htmode 'HT40'
	option band '2G'
	option txpower '20'
	option noscan '1'
	option region '0'
	option cfg '/etc/wireless/mt7615_2g.dat'
	option hwmode '11ng'
	option channel '3'

config wifi-iface 'wifi2g'
	option device 'mt7615e2'
	option network 'lan'
	option mode 'ap'
	option wds '1'
	option disassoc_low_ack '0'
	option ifname 'rax0'
	option key 'goodlife'
	option encryption 'sae-mixed'
	option ssid '2G'

config wifi-iface 'guest5g'
	option device 'mt7615e5'
	option network 'guest'
	option mode 'ap'
	option wds '1'
	option encryption 'psk2'
	option key 'goodlife'
	option ifname 'ra1'
	option guest '1'
	option ssid 'GL-MT1300-b36-Guest-5G'
	option disabled '0'

config wifi-iface 'guest2g'
	option device 'mt7615e2'
	option network 'guest'
	option mode 'ap'
	option wds '1'
	option ssid 'GL-MT1300-b36-Guest'
	option encryption 'psk2'
	option key 'goodlife'
	option ifname 'rax1'
	option guest '1'
	option disabled '0'

config wifi-iface 'guest2g2'
	option device 'mt7615e2'
	option network 'guest'
	option mode 'ap'
	option wds '1'
	option ssid 'GL-MT1300-b36-Guest2'
	option encryption 'psk2'
	option key 'goodlife'
	option ifname 'rax2'
	option guest '1'
	option disabled '1'

I forgot one more step. Go edit this file /lib/netifd/wireless/mtk.sh

Change 2 to 4.

Then reboot the router.

1 Like

So theoretically Beryl can have 2 more SSID added to each channel or is it a total number of 4 SSID? I was thinking you needed to use a seperate PoE Access Point that could handle 4-8 SSID and then do VLAN tagging.

Thank you alzhao

I am not sure about the total. But generally AP chipset can have up to 16 SSIDs. You can change the Max to more than 4 to try.

Bringing this back to the top in case anyone else is wondering if this is still the only way to do this in the latest generation of the GL.iNet routers, i.e. the Flint 2.

I can confirm that the only way to add additional WiFi networks (meaning new SSIDs in addition to the four that can be configured through the GL.iNet UI) is to edit the /etc/config/wireless file and add a new section to the bottom. Be sure to use a unique MAC address as well.

If you use LuCI to add a new wireless network, it only creates a partial configuration in the /etc/config/wireless file that is missing some crucial entries. But what worked for me was to start in LuCI to create the new Wireless network and Interface, then SSH into the router and complete the configuration in this config file.

1 Like

I think you are doing correct on Flint 2.

This post was about old MT1300 with old firmware. Not applicable to Flint 2.

Right, but the process is unchanged, correct? I cannot just use LuCI to create additional SSIDs, I have to edit the /etc/config/wireless file, right?

Pls get the op24 firmware and do everything from luci

https://dl.gl-inet.com/router/mt6000/

Thanks, that's certainly an option. I do like the simplicity of the GL.iNet UI though and wish simple things like additional SSIDs would be supported in it. Perhaps an enhancement for the future?

1 Like

Thanks for the suggestion. Just a lot of work. More features and more bugs. So have to control our desire to add more features.

So glad I ran across this post! New to OpenWRT and GL.iNet routers so I'm learning a lot here.
I have a brand new GL-MT3000 and am trying to add a new/second SSID for the 2.4GHz radio.
I want this new SSID to simply be another connected to the main LAN network and to have no password (open security).
If I am understanding this process correctly, all I'd need to do is:

  1. SSH into the router
  2. Edit the /etc/config/wireless file
  3. Add a new entry at the bottom copying the default wifii2g wifi-iface
  4. Change the MAC address of the new wifi-iface
  5. Edit the /lib/netifd/wireless/mtk.sh file increasing the "local MaxBssidNum=2" value
  6. Reboot

Seems straight forward enough, except for one part. How do I come up with a new MAC address? Or is it just made up and any random HEX characters can be used as long as there's 12?

Update: Looks like the MAC address is automatically set when the ifnam was set to ra2.
However, I didn't need to, and could not do step 5. The mtk.sh file in firmware version 4.7.0 does not look like the one shown earlier in this thread and there is no local MaxBssidNum= line.