Bricked AR750S, uboot "update failed"

Hello, I’d appreciate some help. I was trying to solve another issue, and upgraded my firmware a couple of times then downgraded. The router worked until disconnected and powered up again - after which only the power light came on. Wired ports give a signal but no DHCP. It doesn’t respond on its previous IP address, nor So I’m treating is as bricked.

I tried the uboot procedure and am getting the following error. I’ve tried linux, mac, and windows 7 (all firefox browsers). I’m using the .img file for 3.105, the one it came with before I started all this fun. Can anyone help identify this error or a way forward for me?

Something went wrong during update
Probably you have chosen wrong file (too big or too small) or you were trying to update ART on device with unknown FLASH type (and size) which is not allowed. Please, try again or contact with the author of this modification. You can also get more information during update in U-Boot console.

Should be a .bin file not .img

No, .img is correct for Uboot

I has the exact same symptoms and Uboot problem (except mine was on a AR300M). I tried 3.104 and that worked 1st time.

Thanks. I couldn’t find any .bin files for the AR750S, 3.105.

Oddly, downgrading from 3.201b4 to 3.104 via the UI was what caused this brick, so I avoided that version with uboot.

Trying 3.104 avoided the size issue with uboot… and seems to be back working! Thanks everyone.

1 Like