Doubt about WAN/LAN

Hello!!
I have a GL-AXT1800, I’m configuring it, and now I have some doubts, I explain myself.
My minipc has 2 lan ports, I have installed proxmox and I run a vm with sophos as a firewall. Now, as I´m at work, the minipc is connected to our LAN, however next week (or so) it will be connected to my ISP´s router at home.

Secondly, the gl-axt1800 is connected to the second port of the minipc. And here is the problem…
If I use the WAN port of the gl-axt1800, I don’t have access to the internet, only to the management interface.
pic1
pic2

If I set the WAN port as LAN, I can access to Internet, but I have a banner in the web interface advertising me that the gl-axt1800 hasn’t access to internet, and can’t do things like manage plugins, or update the system.
pic3
pic4

I have the DHCP server disabled via Luci because the DHCP is served by the Sophos, and I use the gl-axt1800 as router (In the Network Mode section).

I’m a little confused, I’m not sure how to manage it…

In simple terms, you want to connect an AXT1800 behind the main router and the devices that access the AXT1800 use the IP assigned by the DHCP of the main router, right?

What is the purpose of using the AXT1800? Is it just to provide Wi-Fi? It sounds like Access Point mode would be more appropriate for this case. Network Mode - GL.iNet Docs (gl-inet.com)

1 Like

Sort of… When I will move these devices (minipc and axt1800) to my home, the DHCP will be offered by the Sophos firewall.

I have already tested the AP mode, there was a considerable delay in the connection to the internet, since I clicked to enter a web until I could navigate it took eons…

PD: Apologizes for my English, it´s not my language…

Hello!

I’m not an expert, but I think you need to plug your Router (AXT1800) into the LAN port from PC 2nd LAN port as you have it now, and set Router a static IP.

Luci>Network>Interfaces>LAN>General Settings & Firewall Settings & DHCP Server tabs

General Settings Tab
If PC is eg 192.168.8.1, set Router to 192.168.8.2 and set IP Gateway 192.168.8.1 and Add Custom DNS also to 192.168.8.1.

Firewall Settings Tab
Firewall Zone as LAN .

DHCP Settings Tab
Ignore DHCP. Your PC will now asign IPs to your devices in your network even if devices are connected to Router.

Also in Luci>System>Startup you can Disable and Stop this Services in Router
-firewall
-dnsmasq
-odhcpd (I think also)

I think you can now access config router page at 192.168.8.2 from your network and have Updates and Internet connection as well in router and devices connected to it,

I hope is what you ask for, my english is very bad.

I previously set up GL-MV1000W and GL-A1300 as a “LAN-only” access point, similar to the method described above by @David.

My procedure:

  1. Disconnect any Ethernet cable connected to the WAN port and any tethering/cellular device connected to the USB port.
  2. Connect to the router via wifi or Ethernet cable connected to the LAN port. Log into the GL.iNet Admin Panel and Disable any Repeater wifi that may have been set up previously. Alternatively, reset the router to start fresh.
  3. Log into the LuCI UI and go to Network → Interfaces → LAN → Edit. On the General Settings &Advanced Settings tabs, set Protocol to Static address, IPv4 address to a static IP on the main LAN subnet (e.g., 192.168.2.10), IPv4 gateway to the main LAN router (e.g., 192.168.2.1), DNS servers to the main LAN DNS servers (e.g., 1.1.1.1, 1.0.0.1). On the DHCP Server tab, Check/Enable Ignore interface to turn off the DHCP server. Save and Apply the settings, then the router will reboot.
  4. After the router has rebooted, plug in an Ethernet cable from the main router LAN port to the GL.iNet router LAN port (no connection on the WAN port).
  5. Connect to the router at its static IP address (e.g., 192.168.2.10) via wifi, Ethernet cable connected to the LAN port, or through your main LAN router.
  6. Log into the LuCI UI and go to System → Startup to Disable and Stop mwan3 from running.

The GL.iNet router will then be connected on your main LAN only, on the same subnet, accessible by wifi or Ethernet. The LED on the router may keep flashing that there is no Internet on the WAN and, if this is bothersome, you can cover it with black tape. Alternatively, turn off the LED by DIsabling/Stopping gl_led from running in LuCI and editing /etc/config/gl_led to set led_enable and led_daemon to ‘0’.

I do not work for and I do not have formal association with GL.iNet

Hello! May be it’s not a correct config but I have two routers (2 AR750) connected by LAN at my main AR750S with my above config, with consecutive IPs and I have mwan3 working with no problems in all of them. I use it just to check with green or red pictures in Overview page in Luci as a monitor :blush:. Metrics and Weight as default, M1,M2,M3,etc and W3.

There are some differences between our 2 methods.

In my procedure, the GL.iNet router acts as a “wireless LAN switch”. Since there is no WAN connection at all, no changes are required on the Firewall because there would not be any traffic going through it (all Internet traffic still goes through the main LAN router as the default gateway). Similarly, mwan3 is not required with no WAN traffic and it just writes a lot of repeated messages in the System Log and may display “No Internet Connection” in the GL.iNet Admin Panel.

I think the WAN port can be changed to a LAN port in Admin Panel, in order to gain an extra Ethernet LAN port, but I have not tested this.

Sorry, I deleted the first photo that I put in the wrong way and it was from my first router (AR750S ) that does have the WAN working and it has created confusion.

I think we have given the same solution connecting the second router via LAN as you say and delegating everything to the first device in this case the MiniPC of acutbal