Flint 2 (GL-MT6000 ) - bug reports - collective thread

Will there also be a chance to have AdGuard updated to the latest release in the next stable firmware version? Thanks :slightly_smiling_face:

the packages I use are above!


config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '6'
        option band '2g'
        option htmode 'HE40'
        option country 'RO'
        option cell_density '0'
        option noscan '1'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 't'
        option encryption 'psk2'
        option key ''
        option disabled '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '36'
        option band '5g'
        option htmode 'HE160'
        option country 'RO'
        option cell_density '0'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 's5Ghz'
        option encryption 'psk2'
        option key ''
        option disabled '0'






so bridges work on the new 4.5.7 beta :+1:, but lan did not wanted to work for internet for me that is fine but something isn’t right, hence this probably would work under normal environments but not under a dumbap one.

upon inspection I see this in my routing table:

default via 10.234.53.1 dev eth1 proto static src 10.234.53.3 metric 10  <- gateway
10.33.77.0/24 dev br-zigbee proto kernel scope link src 10.33.77.120 
10.234.53.0/24 dev eth1 proto static scope link metric 10 
10.234.80.0/24 dev br-wlan0 proto kernel scope link src 10.234.80.2 
10.234.81.0/24 dev br-wlan1 proto kernel scope link src 10.234.81.4 
192.168.8.0/24 dev br-lan proto static scope link linkdown

and my network config:

click to expand
root@GL-MT6000:/etc/config# cat /etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '<snip>'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'
        option macaddr '<snip>'

config device
        option name 'lan1'
        option macaddr '<snip>'

config device
        option name 'lan2'
        option macaddr '<snip>'

config device
        option name 'lan3'
        option macaddr '<snip>'

config device
        option name 'lan4'
        option macaddr '<snip>'

config device
        option name 'lan5'
        option macaddr '<snip>'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.8.1'
        option netmask '255.255.255.0'
        option isolate '0'
        option delegate '0'
        option ip4table 'main'

config device
        option name 'eth1'
        option macaddr '<snip>'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'
        option ipv6 '0'
        option metric '10'
        option force_link '1'
        option delegate '0'

config rule 'policy_direct_rt'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule 'policy_default_rt_vpn'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config rule6 'policy_direct_rt6'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule6 'policy_default_rt_vpn6'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config device
        option type 'bridge'
        option name 'br-wlan0'
        option bridge_empty '1'
        option ipv6 '0'
        list ports 'eth1.50'

config interface 'wlan0'
        option device 'br-wlan0'
        option proto 'dhcp'
        option delegate '0'
        option force_link '1'
        option defaultroute '0'

config device
        option type 'bridge'
        option name 'br-wlan1'
        option bridge_empty '1'
        option ipv6 '0'
        list ports 'eth1.51'

config interface 'wlan1'
        option device 'br-wlan1'
        option proto 'dhcp'
        option delegate '0'
        option force_link '1'
        option defaultroute '0'

config device
        option type 'bridge'
        option name 'br-zigbee'
        option bridge_empty '1'
        option ipv6 '0'
        list ports 'eth1.52'

config interface 'zigbee'
        option device 'br-zigbee'
        option proto 'dhcp'
        option delegate '0'
        option force_link '1'
        option defaultroute '0'

config interface 'modem_1_1_2_6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@modem_1_1_2'
        option reqprefix 'auto'
        option reqaddress 'try'
        option defaultroute '0'

wifi has other interfaces selected wlan0,wlan1,zigbee.

also dnsmasq and firewall are stopped and disabled, what would make the lan interface time out?, it should follow the default gateway from the default route checkbox but somehow that is not happening its stopped at the first hop (the router itself).

as for wireless its going solid 161.55mb/s on 20mhz 2.4ghz, and with 5ghz 160mhz I see 371.09mb/s more likely 400mb/s since its split routed to vpn upstream, if i enable packet steering my speed becomes a little slower, though I have seen faster speeds on the first beta with mediatek sdk i reached there around 200mb/s.

on the OpenWrt snapshot (self compiled forked from r25345-c6319de48b), it is little becoming better on a ax device I was able to reach over 100mb/s on 2.4ghz, but the downwards degradation of the overall wireless quality was still there I had internet in the kitchen but already under 50mb/s, maybe it is a small bit improved but still not enough if i compare it to what i was able to reach with flint 1 outside of my flat or with the mediatek sdk :wink:

^ I haven’t tested 802.1N

edit there seem also issues with the guest wireless network, isolation shows off but its still isolating…

Fullconenat not working in this version, snapshot day 29 is working :clown_face:

same here, there has to be something in the log, but even my connection to the router itself doesnt work.

basically issue starts happening and all web traffic starts to slow then halts entirely, like i said even to the router itself.

even ssh suffers, yesterday when i encountered the issue i tried to ssh into the router but only the banner loaded (not the login prompt). i typed reboot and pressed enter (without the prompt) and it seemed to work. usually restarting the router does resolve the issue, so far.

I did this on mine, and updated no problem

Yeah I’ve noticed that, it’s annoying because I need to reconnect to the router everytime it happens, maybe 4.5.7 will solve this, lot of people having that exact same problem

It’s normal for you this ??

Yup, seems to be the normal log noise.

I can say that it is a limitation… But I can guarantee you that before the reset it didn’t do it… and especially before 4.5.6…

The maximum TX power is 100mW on v4.5.7, v4.5.6 had a maximum TX power of 1000mW, however the range feels the same on my initial test. I didn’t think v4.5.6 was really transmitting at 1000mW but 100mW seems too low, is LuCI displaying a wrong value :thinking:

The MT6000 Snapshot FW 4.6.0 is out. (2024-02-29)

1 Like

100mW is the maximum power allowed in the European Union.
1W is the maximum power allowed in North America (and probably other countries).
In LuCI, set the country where are you are living and it SHOULD set the maximum power according to it.

1 Like

Has anyone tried it?

Running it right now, no issues so far - at least no new ones.

3 Likes

Me too, a least no new ones :rofl:

1 Like

Go to LuCI → Network → Wireless

Everything now is like this:
stats_wireless

That’s normal, the new driver isn’t fully implemented yet.

Not ftp integration yet… More than 1 year delayed…

FTP is dead und pretty old.
Go SFTP instead.