Adguard Home Upgrade


Ever since I’ve upgraded the firmware v4.1 I can no longer update/upgrade Adguard Home in the UI, it seems that I am stuck with whatever version it came with the firmware unlike in the old firmware where you can always update whenever there is a new version available. Has anyone been able to upgrade theirs? If yes, how? Via Luci? Via cli?


There are always problems with each upgrade, so we have disabled the upgrade option for adguardhome, you can try to delete –no-check-update option from /etc/init.d/adguardhome , but I can’t guarantee that this will cause other problems.


Thanks, worked like a charm. :smiley:

1 Like

Did the same it works. Thanks

1 Like

I did this and ran the update. Now my Adguard portal only shows local host and not all clients IPs.

Hi guys,
I am writing here a guide on how to upgrade Adguard Home but not all routers support even enough space storage.

First, turn off Adguard Home on your router page.

Second, have 2 options depending on what do you have a device?

One option (very easy) if you have PC windows then download software call WinSCP
I set my default router is, so your IP router could default
Next open and edit the file on this address: /etc/init.d/adguardhome

and delete –no-check-update

Save it and close.

The second option (very hard) is if you don’t have a PC with Windows, so can use an SSH terminal.
Open the terminal or console and type ssh root@ (type your IP router) enter and type your router password.

type vi /etc/init.d/adguardhome and search --no-check-update then delete. After that Hold Shift and double ZZ.

Third turn on Adguard home from the router page and open a new tab You will be noticed on the top banner about updating the new version or the bottom with the symbol

Very important when you try to upgrade a new firmware router and you will notice no internet because inside the old Adguard Home version I can solve the problem with only one option that I know to use WinSCP.
Turn off Adguard home
Cut or copy one file config.yaml from /etc/AdGuardHome to your PC and make sure the config file is gone from the router.
Turn on Adguard home and open the page about installation then fill in different ports then update latest Adguard home version.
Turn off Adguard home and you will notice a new file config. Put original file confing from PC and turn on Adguard Home.
Double check TCP/UDP have a list of Adguard Home from luci.

I want to thank you for your advises @admon @blackbox GL-inet staff.


Are you also using ssl certificate.

With the upstream servers DoH and DoT to work as encrypted, there is a need for ssl certificate? adguard encrption

Is it possible to obtain ssl certificate without purchasing a domina name?

Of course yes, my upstream all good.

Encryption local ssl are good :blush:


It would be great for GL-iNET devs to upgrade to newer versions of Adguard Home as they promote it in the Flint 2 product page. Also, Adguard has had numerous security fixes since the older release bundled in the FW (4.5.4).

Any tips on setting up the encryption if you don’t have a registered domain of your own? Thanks.


Yes, with LetItEncrypt ssl, but little bit difficult than homeassistant. Wish add plugin duckdns + Let’s Encrypt.

1 Like

Also in my opinion GL.iNet should upgrade the version of AdGuard Home to the latest stable version available with the new firmware or give the possibility to upgrade it with a tool or directly from the router menu as this is an advertised feature and one of the reasons why people buy GL.iNet routers.
I tried to upgrade it from Luci but it didn’t work and I had to reset the router firmware

1 Like

In luci does not same Adguard Home plugin than any frimwares. It is different.