Gl-ar750 dhcp

I have a GL-AR750 I use as a secondary internet connection, I need to completely disable DHCP on the device to let my real server deliver DHCP.

I also had a problem where if I set custom DNS in the router, the router still gives its self as DNS to the clients. However watching the logs, the router is using my custom DNS as its querying server. So why can’t it go ahead and pass the address to the client and let the client contact the DNS directly.

To get around this I have had to configure DNS on most devices to communicate directly to the DNS, and not around about through the router.

If you want the router only works as AP, you need to set it up as AP mode in more settings->network mode.

If you set up custom DNS on the router, it will not affect your client. You can still set up custom DNS on your client. But you can choose to override the DNS query. The router will not pass the DNS settings to the client. This is by design and I don’t think there is a problem. The router can also set up encrypted DNS proxy so it tries to catch the DNS from clients, not pass through DNS to your clients.

To send custom DNS servers to clients:
Start Luci via Advanced settings.
Network->Interfaces
Find the appropriate interface, LAN for me. Click Edit.
Click to open the DHCP Server tab.
Click to open the Advanced Settings sub-tab.
In the DHCP-Options text box, enter 6 and a comma separated list of DNS server IP addresses like:
6,1.1.1.1,1.0.0.1,8.8.8.8,8.8.4.4
Click Save and then click “Unsaved changes” at the top and then click “Save and Apply”

When clients get new DHCP leases, they’ll have the list of DNS servers that you specified.