GL-AR750S-EXT not passing IP info to hardwired devices in Extender Mode


  • I have two small devices I want to be mobile but they must have hardwired connections (wireless is not an option for these devices).
  • I purchased a GL-AR750S-EXT as an extender so it could join the wifi and then I can plug these two devices into the GL-AR750 LAN ports thereby making them wireless/mobile.
  • The GL-AR750 is in Extender mode, joined to the wifi and getting the proper IP address assigned to it (I can see it and it’s MAC on my network).
  • Unfortunately the hardwired devices are NOT getting IPs from the enterprise DHCP and remain (They did initially get DHCP info from the GL-AR750 itself until I turned its DHCP off)

I am told this exact configuration with all of the same devices has worked in smaller network environments but in my enterprise environment the two hardwired devices are not getting IP addresses from the wifi. Does anyone know if this is due to some network security setting or is it a limitation of the GL-AR750 or something else - ? If a limitation, I assume I can manually assign IPs, but I was hoping not to have to do that.

NOTE: I have upgraded the FW. I have disabled DHCP, 2.4G and 5G because I don’t want this broadcasting in my environment. The GL-AR750 is visible on my network.

Thank you for your time and patience with my questions.

I believe the core issue is that Extender network mode uses Layer 3 relayd routing, which DHCP broadcast does not work that well across:

The most common problem is that the client router cannot pass the DHCP message between the main router and the client connected to the client router. Currently it seems to be the hardware/SOC limitation (related to MAC cloning?)

For 2 small devices, can you just assign them with static IP addresses?

I do not work for and I do not have formal association with GL.iNet

Very insightful - thank you wcs2228. I can test with static IPs. Since we were looking to implement more of these configs I was hoping it was just some setting I was missing.