Gl Inet MT3000 Beryl AX Disconnected During Scan in Reapter Mode

Hi all, I have the Gl-inet MT3000 fresh out of the box, with firmware v4.5.16
, there is no issue during the scan process in the repeater mode, but just can’t connect to any network. The router shows connection failed. Is there any solution for that? My other GL inet Opal router has no issue during the scan and repeater mode at all.

1 Like

This happens with my Beryl on 4.5.16 too. You can try the snapshot firmware version 4.60, which may (or may not) help.

My other 5 Gl-Inet routers work well.

yes my other gl.inet opal or flint works fine but the beryl I have this issue.
when I scan I find my hostpot but I can’t connect.
where I can find the snapshot firmware ?
and this is a bug for all the beryl in market ? if i change it that may solve the problem ?

Here GL.iNet download center

I tried this but it’s seems that I can’t upgrade any of the files upload with this format

Have you seen this?:

so the post, saying there issue with the last stable frimwave
and I don’t know how I can go back to 4.5 version or any version that work

This openwrt-mt3000-4.6.0-0420-1713548659.tar is the snapshot 4.60 file you need.

Hello, this is the sanpshot 4.6 that I download it from gl.inet

That link doesn’t show what you downloaded.

Install the one I referred to above : openwrt-mt3000-4.6.0-0420-1713548659.tar

it’s same issue

Have you tried downloading and installing this one from Alzhao with the fixed driver?:

Is your current firmware a release version or some other version? Seems like an alpha version.

as described in some topic here,it’s says that there is issue with the 4.5.16 stable version.
And the alpha and snapshot version fixed that issue because using the open wifi driver…
My Question I want to use a stable and release version thats works perfectly.
I don’t want to use the alpha version or snapshot
I’m already facing issue with encrypted DNS with the snapshot version

1 Like

Sometimes it reports the connection has failed - but in reality the connection is fine and is connected… via SSH you can check with “ubus call repeater status” - look for “state_name” it should show connected…

Remember - no firmware is perfect - there are just so many variables out there… i’ve used version 4.5.16 to connect to a number of devices without issue and a few older ones with issues…

So what stable version I can install it ?
so i dont get interrupted while using wifi connecion

You need to understand that there is no actual “STABLE” version when it comes to GL.iNET. All their firmware versions are a significant work in progress and none of these releases work as perfectly as you would want it to. It is all about experimentation and trial and error here. A good start would be to try the one that supports open source drivers released by alzhao that I linked in a post above on this thread,