Beryl AX at hotel / repeater mode not working

Bought this a month ago. Travelling now and tried to get this working but it is not.
Tried to connect to the hotel wifi. It seems to have connected by then it says there is no internet.

Internal NATed wifi is 192.168.28.1/24. My phones are connected to to.

The hotel wifi is giving a 192.168.0.1 network with a wider subnet of 255.255.254.0.

This worked flawlessly when I am at home when I connected this to a guest wifi vlan I created.

Any ideas?


Beryl AX on firmware <= 4.4.6 has been completely useless for me in many hotels. About 75% of them it won’t even establish wifi connection, then let alone retrieving IP or dealing with captive portals. I’ve reverted back to the Mango which works 100% of the time, so it’s Beryl AX specific issue. This is tragic, as this IS the main use of this device.

However, I’ve tried the beta version 4.5.0 and it seems to work better, and it does at least wifi connect to the SSID and pull a private IP. I’d try the beta version see if it works.

1 Like

Please make sure to read thise guide: Connect to a Hotspot with a Captive Portal - GL.iNet Router Docs 4

Connecting to someone else’s Wi-Fi is ALWAYS a gamble - yes, there may even be Wi-Fi where this is absolutely not possible.

Pls upgrade the firmware as advised by @glinetlvr
After the router can get IP from the wifi network, check about the portal thing, as advised by @admon

1 Like

Tried 4.5 RC. No luck.
Now it keeps saying timeout and asking me to reboot the router. This hotel wifi isn’t even using a captive portal. Just password and dishes out dhcp.

Also I notice some bugs with the admin interface as some buttons do not work on my iphone, such as the reboot popup page.

I would recommend to reset the router, installing the most stable available firmware and try again.
It would be helpful if you can describe the steps you did to connect to the Wi-Fi.

1 Like

Sure I will reset. But no ideal. Which means I need to reload all the VPN settings.
Literally this place doesn’t have a captive portal. Also I don’t think I need to clone my MAC address coz there is no device limit. My 2 phones connect to the wifi without problem. The first thing I did was actually to power on the Beryl and connected my phone to it and tried to get the Beryl on the Repeater mode. It connects and not passing any traffic. Tried turning off AdGuard, and doing all the DNS settings too. So it is definitively a Beryl AX issue. And I tested this at home on my Unifi set up, using a guest SSID/vlan (/24 network) and it worked fine.

Start slowly and add more services (like VPN) over time - so you might see where the issue is.

Sure.
But I wasn’t using this at this time.
Again I tested these at home with 1) wireguard to surfshark server 2) openvpn to my home network.
I tried these using a usb cable tether to my Android phone to provide 4G internet access and both worked fine whilst at home.
Thank you.

I have a firmware which use open source WiFi driver. If you want to have a try pls download and install using this link.

1 Like

This works straight away.
Thank you!!
Though it is my last night here. Will try again in the next hotel.

2 Likes

Is this firmware different from the recent 4.5 release that is now out? Does the 4.5 include the open source wifi driver?

4.5 still have the MTK WiFi driver.

Thanks for the info!

Thanks for sharing the firmware which use open source WiFi. As far as I know the router should support EAP WiFi when using open source WiFi driver, however don’t see the option after upgrading to the firmware you provide. Attaching screenshots for reference, thanks and happy lunar new year.

Router information:

  • Model: GL.iNet GL-MT3000
  • Architecture: ARMv8 Processor rev 4
  • OpenWrt Version: OpenWrt 23.05-SNAPSHOT r23001+727-38c150612c
  • Kernel Version: 5.15.139

CleanShot 2024-02-11 at 15.03.47

Shouldn’t WPA Enterprise be EAP?

You are right, WPA Enterprise should be EAP after comparing with an old firmware.

CleanShot 2024-02-14 at 15.35.12