GL-MT300N-V2 unable to be repeater for wifi network channel 13

Up to today I’ve been successfully using my GL-MT300N-V2 as a repeater for a Mifi device. The GL-MT300N-V2 connects to the Mifi’s wifi network in ‘repeater’ mode, and then I connect a device (Cisco VOIP phone) that only supports ethernet to the GL-MT300N-V2. This means the Cisco desk phone can effectively use the Mifi device’s network through the GL-MT300N-V2.

This suddenly didn’t work today because the GL-MT300N-V2 can’t find the Mifi’s wifi network anymore. If found the reason is that the Mifi has decided to go onto 2.4Ghz channel 13. The Mifi is provided by my work so I have no access to its settings to change what channel it chooses. I’m in Australia where ch 13 is legal, but my GL-MT300N-V2 came from Amazon so might’ve originally been shipped from the US (Australia’s Amazon actually ships a lot of things from the US directly).

My question is can I change the wifi regulatory domain to support channels 12-13 in repeater mode?

I’ve tried lots of things but no luck:
https://feeding.cloud.geek.nz/posts/setting-wifi-regulatory-domain-linux-openwrt/

https://openwrt.org/docs/guide-user/network/wifi/basic


https://medium.com/openwrt-iot/lede-openwrt-setting-regulatory-domain-b18da03f9126


https://openwrt.org/docs/guide-user/network/wifi/wifi_countrycode


https://forum.gl-inet.com/t/does-it-work-on-channel-13/4214/2


https://forum.gl-inet.com/t/wifi-country-setting-in-mango/8495


https://forum.gl-inet.com/t/gl-ar150-channel-13-needed-for-upstream-router-wisp/1581/3

You can ssh to the router and change the wifi settings.

For Japan you can use up to channel 14.

uci set wireless.mt7628.country='JP'
uci set wireless.mt7628.region='5'
uci set wireless.mt7628.channel='13'
uci commit wireless
wifi

Thanks! That fixed it

1 Like