GL-MT6000 poor wifi coverage


I just receive my GL-MT6000 router in replacement of my old TP-Link router (TL-WR841N). I chose the GL-MT6000 because it’s advertised as covering a large wifi area. I’m disappointed as the coverage area is not better and even worth than my TPlink router (old 15 euros 2 antennas router).
Am I missing something in the wifi configuration ?

Thank you.


the Wi-Fi coverage depends on the country you are in - and the laws there. There is therefore a maximum range that no device can exceed; this depends on the maximum permitted transmission power.

You should check whether the correct country has been selected for your Wi-Fi.
This is only possible in luci:

I already set the router for my country (France) but the wifi range is not better.

1 Like

What dBm shows luci and what firmware are you currently using?

It is set to default (20 dBm)

I was hoping to NOT find my issue here, but I have, so maybe a bad batch of routers got sent out?

Opened Box. No peripherals attached, except factory power supply. Set password and timezone, did firmware upgrade 4.5.2 → 4.5.3

Current Firmware

  • Version 4.5.3
  • Firmware Typer elease4
  • Compile Time 2023-12-01 03:08:48 (UTC+00:00)

No other configuruation done to test WiFi 5GHz speeds.

I have been using OpenWRT for about 3 years now, so I know my way around in the “Advanced settings” of the GL-MT6000 router well enough.

Wifi 2.4GHz is A-OK, no issues there.

Wifi 5GHz is NOT good at all.

The WiFi range for the 5GHz radio1 is terrible. I’m upstairs, wood framed house, country/rural area. I’m sitting about 15/20 meters away from my new GL.iNet MT6000 router (Flint 2). I get ZERO bars on my:

  • Samsung Ultra S21
  • Samsung S23 and
  • ASUS Vivobook laptop

at this distance.

Not until I get within 5 to 10 meters of the router will the bars show up.

I’ve changed country to US and even tried CA in Luci.

I’ve tried normal channels, and even some DFS ones. They all work, but the signal is too weak to even show on my devices.

Adjusted up/down the DB transmit power in Luci. It states that “Current power: 30 dBm” Changing country code between US & CA make no difference.

In default WebUI I adjusted Transmit power: Max/High/Medium/Low, no difference.

Restarted radio1 on Luci, but still at my 15/20M distance, nothing.

My old router “Archer C7 TP1750” is in the back corner of my basement, further away from me than the new MT6000 and I can get a good working 5GHz signal from the TP1750 at about 30+ meters away/downstairs.

I’ve tried just about every setting under Luci / Network / Wireless. different modes, narrower bandwidth 80/40/20. Nothing will make it show up on my devices until I get very close to the router.

I will investigate the return policy, but it makes me so mad. I love OpenWRT, it’s all I currently use on CM/Pi4 modules and other RPi4’s. It just works!

Sadly, not on the MT6000.

Any other suggestions welcome before I return this before warranty expires.

1 Like

I don’t know how should perform the 5Ghz frequency compare to the 2.4 Ghz but I have about 180 Mbps at about 30 m distance with 2 concrete walls between my phone and the router in an urban area, what is doesn’t sound too bad to me. At the same conditions the 2.4 Ghz is only 2 to 10 Mbps, so for me this router have some problems…

Jean: I would consider your GL.MT6000 a device that does NOT have my manufacturing issues.

How do I test? That’s too funny.

I stand in front of my router, my phone is about 10 cm (5 inches) from the antenna, and I have 3 bars (not full)

As I walk away from the router, I loose the 5GHz signal, 0%, while I’m still looking at the router on the desk.

I don’t need any fancy frequency spectrograms to know that the 5GHz WiFi is FUBAR on my router.

The app on my phone shows 0dB (zero). at about 10 meters away.

I walk up to my router, 5GHz signal shows on my phone, can never get full bars, even right next to the router.

Alas, my device has a manufacturing defect.

Hi Merrickville,Can you please share the iwinfo with us?

I have the same wifi problem, really mediocre even at 30db with the country PA. My xiaomi ax6000 does not jerk on my ps5 in my room unlike the mt-6000 I even think I separate it and take something else

Do you mean this router? I’m asking for clarification because there’s another Xiaomi router that goes by a similar name.

The Xiaomi Redmi AX6000 has the same CPU and WiFi chips as the GL-MT6000. So if your WiFi is better with your Xiaomi router then there’s either an issue with your WiFi settings or there’s an issue with how the GL-MT6000 was designed.

I had both xiaomi ax6000 ipq5018 and redmi ax6000 the redmi does not have the problem of high ping

Yeah, that’s the other one I’m thinking of. It looks a little like a sound bar with antennas :smile:

But yeah, if you haven’t already check that your GL-MT6000 and Xiaomi Redmi AX6000 are using the exact same settings. So same WiFi mode, same WiFi channels, same channel widths, country and transmit power. And you’d want both of them setup to use the same DNS settings too.

Personally I’ve found my ping to be exactly the same as it was with my eero Pro 6.

root@GL-MT6000:~# iwinfo
wlan0     ESSID: "GL-MT6000-b06"
          Access Point: 94:83:C4:XX:XX:XX
          Mode: Master  Channel: 6 (2.437 GHz)  HT Mode: HE20
          Center Channel 1: 6 2: unknown
          Tx-Power: 30 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -91 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ax/b/g/n
          Hardware: embedded [MediaTek MT7986]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "GL-MT6000-b06-5G"
          Access Point: 94:83:C4:XX:XX:XX
          Mode: Master  Channel: 36 (5.180 GHz)  HT Mode: HE80
          Center Channel 1: 42 2: unknown
          Tx-Power: 30 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -92 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/ax/n
          Hardware: embedded [MediaTek MT7986]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

I was getting very low upload speed on 5Ghz from about 20ft away - so i just changed the 5ghz bandwidth to 160MHz and it helped a lot.

It’d be good if a few of us could do this simple test.

  1. Set the correct country code for both radios so that you’re using the legal power limits
  2. Install an app like WiFiAnalyzer or WiFiman on your phone
  3. Go outside and walk away from your home a little
  4. Check if 2.4 GHz or 5 GHz has the stronger signal

For me 5 GHz always has the stronger signal, which shouldn’t really be the case since 2.4 GHz is supposed to easily pass through walls and other obstacles.

So is it a firmware issue or a hardware design issue? Hopefully it’s not the latter and things can be improved without certification being an issue.

I did the test comparing with my old router, and the wifi power on wifi analyser is almost the same, so don’t worry about that. And both router are new generations so the wifi coverage is better than old routers.

My only concern is about the latency and wifi speed on 2, 4GHz, comparing to my old router, MT6000 is awful.

I think your issues different in general, since for me the latency is minimal across both 2.4GHz and 5GHz. And I’ve done some testing and found the 2.4 GHz range to be worse from the GL-MT6000 than my 5 year old ISP provided router, which of course means that the speed is impacted too.

In your case I’d suggest sticking to 20 MHz for the 2.4 GHz radio, since 40 MHz often overlaps and will slow down your own network as well as your neighbours. And of course you should only use channels 1, 6 or 11.

Most of my devices support 5 GHz, so I’m not too bothered by the 2.4 GHz range. But a lot of IoT devices only support 2.4 GHz and the product page promises strong signals throughout medium sized homes, so I think that could result in some negative reviews when the product becomes available on Amazon.

I will not be complacent with GL inet. I bought a router that promises better speeds and performance than my other routers, so I want the problems resolved. I tested both bandwidths, 20MHz and 40MHz. Both are worse than my old routers. I tested:

  • Xiaomi Mi Router 3G
  • GL-AR750s
  • GL-MT3000
  • Huawei AX3 Pro
    In all of them I have much better performance at 2.4GHz than the MT6000. So there is definitely something wrong with the router on that band, and I’m not the only one to notice it. I’m not talking about range, the router is great, I can connect to WiFi from afar, but the 2.4GHz performance is horrible. It will definitely have bad reviews in this aspect if any adjustments are not made.

See this, a friend generated a pacap using tcpdump on 2 devices connected via the MT6000’s 2.4ghz, see how many ACKs with dup. It is a network problem with the MT6000.


@blackbox Also, I’m in the 4.5.3 beta, where the default value for power is 36dbm. So there’s the “high wifi power bug” but it the best firmware for me, so far.

1 Like

I wonder since i see this 2.4 ghz range problem also occur on the vanilla OpenWrt snapshots for me, ive readed mediatek also have their own firmware calibrate files.

Someone tried compiling OpenWrt with one of mediateks ?

I wish I knew how to compile it with it included but maybe someone else tried, did it made a noticable difference?


Nvm, what i wrote above ^, mediatek sdk is closed source, mt76 is OpenWrts own flavoured custom driver, so its not so easy to compile without permission.