Help flashing GL-AX1800 Flint with ExpressVPN Aircove firmware


I have a GL-AX1800 Flint running firmware 4.2.0 release3

I’d like to flash to ExpressVPN Aircove firmware. (The GL-AX1800 Flint and the ExpressVPN Aircove is, in effect, the same hardware.)

I’ve tried uploading the latest “expressvpn_router_4.4.2.2647_release_aircove-ax1800.img” firmware as a ‘Local Upgrade’ to the GL-AX1800, but I get a “Testing the firmware with sysupgrade failed” error.

In previous posts on this forum, I see users have successfully flashed from GL-AX1800 Flint → Aircove.

I’d be grateful for any help and/or advice, please, as to how to flash from the GL-AX1800 Flint to the Aircove firmware.

Many thanks in advance.

1 Like

If you’re using ExpressVPN’s firmware you should really be asking them.

They may/may not require you to use U-boot to flash than just rely on the GL GUI per that error msg re: failed firmware test. It’s not clear to what extent are their customizatons.

Thank you for your post, bring.fringe18

For anyone who’s wondering, the flash of the GL-AX1800 with the Aircove firmware was straight forward using UBoot.

hello @simulacrum ,
please can i have a short tutorial how to flash my flint with aircove firmware ? if you don’t mind of course. i highly appreciate your help. thank you.

Hi Karimko

Please check your messages for a short tutorial.

Many thanks.

1 Like

Were you able to inject the Express VPN operating system?

Hi All, I’m about to undertake this venture!

So as I understand you go through the special UBoot startup procedure directly connected and then use the Aircove .img firmware to flash from there?

Anyone confirm that the img file works?

I’m asking because I’m used to .tar files at that juncture.

Best Regards,


Please could i have the tutorial as well. My AX1800 arrives today,

Did the tutorial work ok? Could you send it to me please.

I would also like to install the expressvpn firmware on the GL-AX1800, could you help me with a guide?
Thank you

Hi, have you installed expressvpn firmware on the GL-AX1800?
It worked ?
If you have a tutorial, could you send it to me?
Thank you

For those of you who have requested instructions, I’d suggest doing the following:

  1. Read the introductory guide to flashing firmware using UBoot, found at:
    Debrick via Uboot - GL.iNet Router Docs 4

Note you’re not going to debrick your router. You’re going to use UBoot to flash the Aircove firmware to your GL-AX1800 Flint router.

The Youtube video within that guide is also strongly recommended. So:

  1. Watch the Youtube ‘How to Use UBoot to Debrick Your GL.iNet Router 2021’ video at:

At this point, you should be clear on how to use UBoot with your Flint router.

  1. Sign into the ExpressVPN router setup page:
    Sign in to your account | ExpressVPN

  2. Select and download the latest Aircove firmware
    n.b. Use 7-zip or similar to generate a SHA-256 hash value for the firmware .img file and confirm it matches the SHA-256 value provided by ExpressVPN.

  3. Use UBoot to flash the Aircove .img file to your Flint router.

  4. Once the Aircove’s wifi is visible and broadcasting as Aircove-xxx, you’ll know the flash is complete. You can always wait a few extra minutes to be sure.

I hope the above helps.


I just finished the procedure and everything went smoothly.
A special thank you to simulacrum and to all the others. Thank you

hello , yes and a big thank you to @simulacrum who guided me, how to send you an email ?

hello , yes and a big thank you to @simulacrum who guided me, how to send you an email ??

hello , yes and a big thank you to @simulacrum who guided me, how to send you an email

Great instruction and advise!

Interesting, thank you very much for the guide.
I have the Axt1800 and I have been told by Glinet that the new Aircove GO is built on this, so I have been wondering whether the firmware for the GO would install.
I suspect/hope that it will.

Well, that was fairly painless (after a bit of a wait where I expected the uboot gui to give me an indication that everything was complete).

So my Axt1800 is now an Aircove Go AXG1800 and everything seems to be working.
But this firmware is so cut down and limited.

The app interface is OK-ish and the various servers I was having issues with because the manual configs no longer worked (and Expressvpn just keep telling me that their techs are working on the problem) all connect immediately via the app.
But there’s no network file sharing (of my usb or sdcard) and no Syncthing, I can’t find any way to install any other files or functions.
Ssh won’t connect, so no way to add Syncthing that way. No Luci.

So, it would seem that the Aircove Go is a pretty expensive travel router aimed primarily at gamers who want to connect their Xbox to the hotel Wi-Fi while on holiday, and genuine travellers with a need to keep files etc synced while away have been left out.
It’s working for the time being but I intend to restore the original firmware tomorrow.
Unless, of course, theres a way to install Syncthing that I haven’t yet found on Google?

Over to you guys for suggestions.

My advice to anyone considering this, unless you specifically want the Expressvpn user interface, which is to be fair not too bad, don’t bother. The functions you lose outweigh the benefit of the gui (in my humble opinion).
Plus, getting back to the uboot interface was a ball-ache because the ip addresses changed (to be expected) but so did the reset button/led combination.

But just incase you try.

Follow the instructions from here:-

Uboot on AX1800 does not work! (post 22)

But use :-

Static ip to

Third led flash (blue)