Let's get the MC7455 working in MiFi!


#1

I have a brand spanking new Mifi 2.5 w/2.271 and a generic Sierra Wireless MC7455, not from Dell or Lenovo.

I have it configured for QMI based on what I am seeing from dmesg:

[ 903.038831] usb 1-1.2: USB disconnect, device number 4
[ 903.060545] qmi_wwan 1-1.2:1.8 wwan0: unregister ‘qmi_wwan’ usb-ehci-platform-1.2, WWAN/QMI device
[ 912.750561] usb 1-1.2: new high-speed USB device number 5 using ehci-platform
[ 912.871616] usb 1-1.2: config 1 has an invalid interface number: 8 but max is 3
[ 912.877495] usb 1-1.2: config 1 has no interface number 1
[ 912.918220] qmi_wwan 1-1.2:1.8: cdc-wdm0: USB WDM device
[ 912.923764] qmi_wwan 1-1.2:1.8 wwan0: register ‘qmi_wwan’ at usb-ehci-platform-1.2, WWAN/QMI device, e2:e2:f5:20:29:50

So what’s next Alfie? How do we get this guy going?


MiFi LTE questions
#2

Just set up and use QMI mode, it should work. It has wwan0 which can be used as QMI mode.

I didn’t see anything special.


#3

It doesn’t seem to work. It appears as a device under tethering, but never connects.

Also, for some reason no drivers seem to load for the com ports. Any idea how to fix that?

T: Bus=01 Lev=02 Prnt=02 Port=02 Cnt=02 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=1199 ProdID=9071 Rev= 0.06
S: Manufacturer=Sierra Wireless, Incorporated
S: Product=Sierra Wireless MC7455 Qualcomm® Snapdragon™ X7 LTE-A
S: SerialNumber=LQ81254889041021
C:* #Ifs= 4 Cfg#= 1 Atr=a0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E: Ad=83(I) Atr=03(Int.) MxPS= 10 Ivl=32ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E: Ad=85(I) Atr=03(Int.) MxPS= 10 Ivl=32ms
E: Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 8 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan
E: Ad=87(I) Atr=03(Int.) MxPS= 8 Ivl=32ms
E: Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms


#4

IIRC, some of the USB-based Sierra (et al.) modems need a “kicker” to flip the USB configuration space from something more useful for Windows machines to that for generic QMI/WWAN. While I’d be surprised that’s not part of the (GL) firmware, it may be instructive to do the equivalent of lsusb -v -d 1199:9071 from a Windows machine once it’s running in WWAN mode.

Either that, or, despite it being seen as a QMI device, the kernel may not be “ready” for such a new device (quirk tables, etc.).


#5

Can you search the software repo (using the UI) for Sierra and install necessary kernel modules? then reboot the device. I don’t think Sierra drivers are all installed.

I am not sure what you said is the problem. But need to check in more details. Please let me know if you installed Sierra modules.


#6

I’ve been doing a lot of research over the past day, and I think this may be the right answer. I am not a Linux guy, so I am admittedly struggling.

What I have found is references to a “Direct IP” approach that this card uses and then something else about maybe needing a 4.5 kernel for QMI?

I guess I thought that it would work using old-style modem mode, but the com port drivers don’t load.

The following Sierra packages are installed by default:
kmod-usb-net-sierrawireless 4.4.92-1
kmod-usb-serial-sierrawireless 4.4.92-1


#7

Okay, I discovered that this modem uses the qcserial driver. Once I installed that, the com ports are being setup as /dev/ttyUSB0 - 2.

The GLInet GUI does does not see them though, and I cannot get a connection even if I set them up manually in the network connections screen.

Any ideas on what to try next?

Also, really excited about the x750. Any chance you could support Sierra modems out of the box on that one? Or partner with the ROOTER Project to support the GL Mifi products?


#8

Do you mean that there is ttyUSB0 to 2 but the UI cannot configure that?

so, still old question, can you set up in QMI mode? QMI is not tethering.


#9

Alright. Here is where I am at.

I got the com ports working and they are now visible to the GL-Inet webpage.

I setup a remote logging server to make gathering logs easier. This is what I am getting from the connection attempt now:

6/5/2018 11:49 AM Notice 192.168.88.1 Interface ‘modem’ is setting up now
6/5/2018 11:49 AM Info 192.168.88.1 AP Ok=0
6/5/2018 11:49 AM Info 192.168.88.1 network(caIfnames) = wan wan6 wwan modem tethering
6/5/2018 11:49 AM Info 192.168.88.1 STA Ok=1
6/5/2018 11:49 AM Info 192.168.88.1 Scan and fixing the problems
6/5/2018 11:49 AM Info 192.168.88.1 bIsAutoRepeater = 0
6/5/2018 11:49 AM Info 192.168.88.1 Get Default wifi…enabled.
6/5/2018 11:49 AM Info 192.168.88.1 check wpa runing =
6/5/2018 11:49 AM Info 192.168.88.1 AP-Only Mode!
6/5/2018 11:49 AM Notice 192.168.88.1 modem (5237):
6/5/2018 11:49 AM Notice 192.168.88.1 pppd 2.4.7 started by root, uid 0
6/5/2018 11:49 AM Info 192.168.88.1 abort on (BUSY)
6/5/2018 11:49 AM Info 192.168.88.1 abort on (NO CARRIER)
6/5/2018 11:49 AM Info 192.168.88.1 abort on (ERROR)
6/5/2018 11:49 AM Info 192.168.88.1 report (CONNECT)
6/5/2018 11:49 AM Info 192.168.88.1 timeout set to 10 seconds
6/5/2018 11:49 AM Info 192.168.88.1 send (AT&F^M)
6/5/2018 11:49 AM Info 192.168.88.1 expect (OK)
6/5/2018 11:49 AM Info 192.168.88.1 AT&F^M^M
6/5/2018 11:49 AM Info 192.168.88.1 OK
6/5/2018 11:49 AM Info 192.168.88.1 – got it
6/5/2018 11:49 AM Info 192.168.88.1 send (ATE1^M)
6/5/2018 11:49 AM Info 192.168.88.1 expect (OK)
6/5/2018 11:49 AM Info 192.168.88.1 ^M
6/5/2018 11:49 AM Info 192.168.88.1 ATE1^M^M
6/5/2018 11:49 AM Info 192.168.88.1 OK
6/5/2018 11:49 AM Info 192.168.88.1 – got it
6/5/2018 11:49 AM Info 192.168.88.1 send (AT+CGDCONT=1,"“IP”","“epc.tmobile.com”"^M)
6/5/2018 11:49 AM Info 192.168.88.1 timeout set to 30 seconds
6/5/2018 11:49 AM Info 192.168.88.1 expect (OK)
6/5/2018 11:49 AM Info 192.168.88.1 ^M
6/5/2018 11:49 AM Info 192.168.88.1 AT+CGDCONT=1,"“IP”","“epc.tmobile.com”"^M^M
6/5/2018 11:49 AM Info 192.168.88.1 OK
6/5/2018 11:49 AM Info 192.168.88.1 – got it
6/5/2018 11:49 AM Info 192.168.88.1 send (ATD99*1#^M)
6/5/2018 11:49 AM Info 192.168.88.1 expect (CONNECT)
6/5/2018 11:49 AM Info 192.168.88.1 ^M
6/5/2018 11:49 AM Info 192.168.88.1 ATD
99***1#^M^M
6/5/2018 11:49 AM Info 192.168.88.1 CONNECT
6/5/2018 11:49 AM Info 192.168.88.1 – got it
6/5/2018 11:49 AM Info 192.168.88.1 send ( ^M)
6/5/2018 11:49 AM Info 192.168.88.1 Serial connection established.
6/5/2018 11:49 AM Info 192.168.88.1 [ 705.286126] 3g-modem: renamed from ppp0
6/5/2018 11:49 AM Info 192.168.88.1 Using interface 3g-modem
6/5/2018 11:49 AM Notice 192.168.88.1 Connect: 3g-modem <–> /dev/ttyUSB2
6/5/2018 11:49 AM Info 192.168.88.1 CHAP authentication succeeded
6/5/2018 11:49 AM Notice 192.168.88.1 CHAP authentication succeeded
6/5/2018 11:49 AM Info 192.168.88.1 No response to 5 echo-requests
6/5/2018 11:49 AM Notice 192.168.88.1 Serial link appears to be disconnected.
6/5/2018 11:49 AM Notice 192.168.88.1 Connection terminated.
6/5/2018 11:49 AM Notice 192.168.88.1 Modem hangup
6/5/2018 11:49 AM Info 192.168.88.1 Exit.
6/5/2018 11:49 AM Notice 192.168.88.1 Interface ‘modem’ is now down

There are some things with this modem that make it a little more complicated to deal with, but I think that I have got those things sorted. I am using a T-Mobile SIM card that is provisioned for tethering/hotspot use as it is what I am using in my old MiFi with EC-25 card. This SIM works with the MC7455 in Windows as long as the adapter is in MBIM mode, which doesn’t appear to work in the MiFi.

Tethering with this card does not work at all.

Let me know what Else I can do.


#10

Forgot to mention that QMI does not work. I can log an attempt if you like.


#12

I want to sincerely thank you for this post. Between trying my modem (340u) with Rooter and your point on qcserial, after days of work, I was able to get mine to function properly. I hope you find resolve to your issue.

Edit: QMI works too. I had to install luci-proto-qmi and kmod-usb-net-cdc-ether. I then built the connection in the gl inet interface and rebooted. Then I removed creds and set auth to none and made sure it was set to boot on startup in luci. Finally I rebooted and it was brought up automatically. QMI is definitely ideal so I’m glad I got that working too.


#13

Can you clarify how you didi this?


#14

In LUCI on the interface. When you install those packages it changes from WWAN to QMI Cellular too. I would have built the interface in LUCI too but your software doesn’t allow it.


#15

Major update:

TL;DR: SIM card reader seems to be defective in my new MiFi 2.5
Edit: I am an idiot. The SIM card was inserted incorrectly.

Details:
I have two MiFi routers:

  • MiFi 2.2/EC25-A card - year old
  • MiFi 2.5/MC7455 card - brand new

The following packages needed to be installed to get all the drivers for the MC7455:

  • kmod-usb-serial-qualcomm
  • kmod-usb-net-qmi-wwan

I got the MiFi 2.5 working with an external USB device using /dev/ttyUSB2. This made me wonder if there was a problem with the SIM card, so I swapped that out, but it did not help. The problem is that the connect proceeds to the end, but then an error “No response to 5 echo-requests” is seen.

I put the EC25 in the MiFi 2.5 and it stopped working with the same error. When I placed the MC7455 in the MiFi 2.2, it connected immediately. I am pretty sure that the SIM card cannot be read in the new MiFi 2.5.

The remaining problems are:

  • MiFi 2.2 w/ MC7455 will drop the connection soon after being established.
  • QMI does not work in either router. I have seen references to the kernel needing to be 4.5 or higher for QMI to work with the MC7455 due to raw-ip mode.

@alzhao What do you think?


#16

Update 2:

  • Dropped connection:
    This dropped connection problem persists. I cannot tell from the log files what is causing it. It seems like when the FW config is reloaded after the 3g-modem is up.

  • QMI:
    This does not seem to work at all on this build of openwrt. I have flashed the AR150 build of ROOter on this MiFi for testing and surprise! It works perfectly in QMI mode. They seem to have a really nice feature set for managing modems as well. It turns out that QMI does not seem to work with this modem in ROOter either, but MBIM does. Unfortunately, the driver for MBIM mode does not seem to be available on the MiFi.

  • Using alternative builds of openwrt:
    The MC7455 in MBIM mode with the AR150 build of ROOter on this MiFi and it works great except that the LEDs don’t work. Any idea how to fix that?


#17

As ROOter is openwrt as well, you can config the LEDs manually. It should be /etc/config/system


#18

I talked to the admins over at the ROOter forums, who graciously built a bin for the MiFi after I was unsuccessful.


#19

So is everything works good now?

We sent samples of MiFi to ROOter team a while ago.


#20

Hi, I tried to connect the mc7455, which is in an usb adapter, to via Mifi usb port.

Modem is in Mbim mode.
I tried with actual Golden Orb for Ar150, but it seems USB port on Mifi is not working at all with AR150 firmware.

Any news of Rooter for Mifi?


#21

https://ofmodemsandmen.com/upload/

About half way down.

Works great!