Looking for DLNA for GL-MT300n-V2


#1

Since Minidlna is no longer available does anyone know of an alternative?


Something wrong?
#2

@Nekora Ipk is available in here.


#3

Yes, that is EXACTLY what im looking for, All up and running and ready for me to take it on the road. Mini router for the win. Thanks kyson-lok


#4

Hi Nekora and kyson-lok,

I have this GL-MT300n-V2 router, but the UPnP / DLNA is not working? “miniupn” looks like it is installed already? How can I get UpnP / DLNA to work? I see the link to the file from kyson-lok, but how do I install that “minidlna…ipk” on this router?

Also, I have a USB stick connected with multimedia files with sharing enabled, but it does not show up anywhere?

Thanks,
Phil (phd21)


#5

Ah the journey to change it into a portable file/media server.
1> I had a similar problem with my USB, first check to see if you can see the files listed on the web interface under Home>(usbdrive) if you can see your files there and click on them to download then at least we can say thats working. At first i could not view the usb drive on the windows network, this was due to the fact my windows file and printer sharing was broken and would not stay on no matter how many times i tried… i had to go into windows > settings > Network and settings : Reset Network to get it to turn on. Anyway if you have an android phone you could always try something like es file explorer then open the ip of the router to see if the files are shared on the network, not sure what else to tell you there, good luck?

2>GL-MT300n-v2 as DLNA media server: Hoo boy, not built in, but the link posted by Kyson-lok is the softwear yoou need to do it… as for installing it. I THINK this is the process… but could be wrong.
Also you will need softwear to SSH into the router and file transfer to it, there may be easier ways but i used Putty and WinSCP to do it.
Anyway steps as follows: Transfer the LPK Kyson-lok linked to your router, i suggest into the tmp folder.
SSH into the router and log in with your username and password (usually root and whatever password you set as admin when setting up your router)
First make sure your up to date with your lbs by running "opkg update"
Once that’s done (assuming you get no errors) you should be able to run the lpk by inputting “opkg install /tmp/minidlna_1.1.5-3_mipsel_24kc.ipk”
… okay then you need to instal the luci interface so run "opkg install luci-app-minidlna"
and then we want it to run the dlna every time the router loads so run "/etc/init.d/minidlna enable"
and the turn it on “/etc/init.d/minidlna start”

after that it should be on your network… i think… i may have missed a step.

ether way hope some if not all of this helps, if not… eh, im not the best to ask as im really a novice at this.


#6

Hi Nekora,

Thanks for replying, are you another forum member or part of GL-inet team?

I use Linux Mint exclusively, specifically version KDE 18.3 based on Ubuntu 16.04 and Linux Mint KDE 17.3 based on Ubuntu 14.04.

  1. I can see the files on my USB stick through the router’s web interface under “files”. But Like another post on this forum, I am using Repeater mode with Wisp to a parent router without UPnP enabled which I cannot change and that should not matter. I want this router to be the UPnP DLNA server for anything that connects to this router. Unfortunately, I do not have an Android smartphone yet.

GL-MT300A media server - general - GL.iNet
https://forum.gl-inet.com/t/gl-mt300a-media-server/2046

  1. I have many various SSH capable applications, & File Managers with various network options including SSH, & console terminal command options, etc… But, what is the login name if any for this router, the password is my login password, and the SSH port is usually 22, but the Router’s Wan port shows 83? Is there a default folder, like “root” or “/”? Can you show me one or more of the commands you used?

I tried to install the luci-app-minidlna using the Router Apps, but it would not install "Cannot satisfy the following dependencies for luci-app-minidlna:* minidlna * "

I already have various Linux desktop applications for UPnP/DLNA streaming server which work great like UMS (Universal Media Server), Kodi, Plex, etc… but I want to see if this cool mini router could do it.

Regards,
Phil (phd21)


#7

Hi Nekora, & kyson-lok,

Your replies helped me a lot, thank you.

I have “minidlna” software installed now for UPnP/DLNA access and it is working perfectly, automatically added the USB stick files too. I think this package should have been included since they already had the “luci-app-minidlna” available which depends on the minidlna package? And, the already installed UPnP/DLNA options are dependent upon the Internet network’s router you are connecting with having UPnP/DLNA enabled? Actually, I think “miniDLNA” would be a better default option for UPnP/DLNA then their default pre-installed UPnP option using “miniupnp”, unless there are some settings that can be changed for that to work without dependency on the “parent” router having UPnP enabled.

It took me awhile to figure out this router’s interface, but after looking at another post, I found there is a much better administration interface menu with options I am more used to over the default minimal basic configuration menu, just click the Advanced Settings in the upper right of the router menu, use “root” for login username and your password, or see link below.

http://192.168.8.1/cgi-bin/luci/admin/system/admin

The minidlna shows up in the Admin Services Menu GUI and can be easily started or stopped and configured to various network adapters, and other options, etc… very nice. And, many other features are available, like advanced firewall access with QoS, ports setup, etc…

It did take me some time to figure out “scp” ssh transfer program, since I have not used that before (easy to use). I downloaded the “minidlna_1.1.5-3_mipsel_24kc.ipk” from the link “kyson-lok” provided, opened a console terminal window (command prompt) in that folder, and just typed in
scp minidlna_1.1.5-3_mipsel_24kc.ipk root@192.168.8.1:tmp

entered in my password, and it copied the file into the router’s “tmp” folder, because I did not know a better place to put it. Obviously, they already have a software applications packages folder somewhere?

then from the console terminal prompt I used SSH to login into the router
ssh root@192.168.8.1
Entered in my password and from the router’s root prompt
root@GL-MT300N-V2:#
I typed in
opkg update
to get into the tmp folder
cd tmp
and ran this command to install minidlna
opkg install minidlna
To exit the ssh session, type in
exit
then close the console terminal (command prompt) window

Then I went back to the browser and the router’s menu to the applications (software) option, searched for “dlna” and made sure miniDLNA was installed and then installed the “luci-app-minidlna” package, went to the Services Menu, and there was a new entry for miniDLNA with an easy graphical interface, checked to enable it, selected network interfaces for this like the Wireless Network: Master (lan), clicked save and apply, and it works great. I have a Samsung Smart Blu-Ray DVD player that easily found the multimedia content connected to the router’s USB port (my USB stick). I am assuming because this mini router is powered by a USB port or USB (5v) power supply, that if I wanted to use a USB external hard drive which usually requires more power or multiple USB sticks, I would need to use a USB hub with its own power supply to attach to this router’s USB port.

FYI: I did not need to have the main menu’s UPnP enabled, or the Wan Access enabled either for the “miniDLNA” to work.

Have a great day and night wherever you are…


GL-MT300A media server
#8

as you have got it working, can you share how it perform when streaming video? e.g. if you have a 4K video and play for 2 hours, is the router still alive?


#9

Hi alzhao,

Unfortunately, I do not currently have any 4k video capable devices like a 4k smart TV, 4k computer monitor(s), 4k game console, smartphones with 4k resolution, etc… My older non-smart Samsung LED TV only has 720p resolution and I am not sure what max resolution my older Samsung Smart Blu-Ray DVD player is capable of, but I think it maxes out at 1080.

I already tested this with 1.5 -2 hour long 1080 and 720 resolution videos and it worked perfectly, quickly too, no “buffer” stuttering either.

I will see if I can locate a 4k 1.5 - 2 hour video (typical movie length) to test this with. Of course, anyone else can do the same thing and report back to us as well.

Best regards,
Phil (phd21)


#10

Hi alzhao,

I updated my last replies.

I have not had time to locate 4K resolution video(s) yet, so I have not been able to test that, which since I do not have any 4K video capable devices would not be a really good testing environment anyway.

But I have another question. I removed the USB stick from the router to add more video and music files, but when I reinserted the USB stick, waited a little while, the router and “miniDLNA” software did not refresh itself to show the new media content, it remembered only the older content? I rebooted the router through its menu, and that worked. I will assume if I powered off and then on the router that would have refreshed the available media content as well. Is there a setting in the router or the “miniDLNA” software to have it auto-refresh (re-read) the available content from whatever sources I added, like the USB stick, etc…?

Thank you,
Phil (phd21)


#11

I think the problem is that the disk is not unmountrd correctly. So after you plug again, it is not mounted properly as well. The old file may not be readable either.

I suggest you to power off the router the detach the disk, which is better for your disk.


#12

Hey Tyson,

I tried to CLI install minidlna on the AR300m using this file but got the following errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for minidlna found, but incompatible with the architectures configured
  • opkg_install_cmd: Cannot install package minidlna.

I assume because it’s the wrong router. I don’t suppose you have an .ipk file for the AR300m?

Thanks if so.


#13

I think you download the wrong ipk. Could you please explain more how did you do?