MT3000 Beryl AX Open Source WiFi driver firmware

Yes, the newer irmware can release on friday. But the inner test won’t be done. So it may also have some issue.

Is it a 23.05 version with closed wifi or 23.05 open?

23.05 With open version WIFI. The official release is close version. Now open version is just in beta

1 Like

but the 2.4ghz wifi problem is not related to 23.05? because in this version that you released a while ago, you had the same problem as the mt6000.

1 Like

Appreciated for using the Open Source WiFi firmware, now I can enable EAP AP with it.
Just wondering if you’re going to release the firmware with opensource driver and closed source

It’d be great if the closed sourced is compiled with EAP support so I can still support my use case.

My use case for EAP is just to set up AP with client certificate authentication with RADIUS which is deployed in my office setting, previous closed driver firmware was unable to do it, but when I flashed to open source openwrt 23.05 I was able to set up EAP AP, however I don’t want to lose all the handy functionality that gl-inet team has added to make my life easier (vpn, adguard, etc.) so this release really helped my use case and huge applause to gl-inet team for maintaining it.


2.4ghz wifi problem is related to 23.05. And the close version is more stable.

1 Like

Hello every. our beta firmware is ready. but in some test senario 2.4G also have WIFI issue like MT6000. So if you care about it, please wait for next verison after Chinese new year. Thank you all for your kindly support and patience.



Any changelogs or fixes compared to the alpha version?

1.Fix get online upgrade status not correct
1.Fix connect some pppoe fail with IPv6 disabled
1.fix connect AP with width great than 20M fail while in 20M


Not sure if this is related to 4.6.0-r2-2.1-13.20 update, I updated it remotely via Goodcloud, update was successful and I can access the remote ssh from goodcloud side, however, when I tried to open the admin console, it redirected to IP instead of the rtty url, since I’m not connected physically with the device I can’t open the admin console for now.

Had done several updates remotely (for other devices) and they were successfully upgraded and pointed to the correct URL, only this time it happened.

Not sure if it will help but run
/etc/init.d/gl-cloud restart by SSH.

Tried it and already rebooted the router remotely for few times, still no effect

Is there any new update to this firmware, 4.6? I’ve been using it for the past 2 days, it works great but I’ve noticed after a few days the wireless connection is not very stable. If I disconnect from the wifi connection and reconnect it works for a few min then it slows down so much it does not load a web page anymore until I disconnect and reconnect. But will never have stable connection until I reboot the router. I didn’t see anything unusual with the log. Before this firmware I’ve been using the 4.5 stable version and it runs for weeks without reboot.

1 Like

Just came here to say the same thing, what a timing haha
I’ve been noticing it, especially the last 2-3 days. I’m still on the first alpha released. Thinking to downgrade to 4.5

Unfortuately Engineers all went to holiday for 2 weeks!


Hi there! Are you using the Beryl as a repeater for a 2.4ghz Wi-Fi network? Do you have more than one station with the same SSID? I had a similar issue with my Opal, it would disconnect every few minutes. I found a solution on the forum: try to set the router to connect to a specific MAC/station SSID. That fixed it for me, because I had two stations/APs, not a mesh system, with the same SSID and the router was switching between them, causing the disconnections.


I’ve just setup a schedule to reboot every day early in the morning, hope this will fix the problem until a new update is available. Hopefully up dates for 4.6 will be on the download page so we can see the fixes in the update.


Yeah I hope so, I will try the second beta firmware they posted here, if that doesn’t solve it I will downgrade until we can try the next firmware

the whole firmware is a mess. I just bought this product recently and didnt expected it to be this bad. all the youtube reviews made me bought this router but its not useable. even the 4.5 firmware was just bringin me trouble with my WiFi.

1 Like

I like it when people complain about problems without going into more detail. You haven’t created a forum post here with the problem description - how is anyone supposed to help or even fix the problem?