MT3000 Beryl AX Open Source WiFi driver firmware

I’m not sure what problems you are having but when I was on 4.5 latest release, it was very stable. It just that I plan on using it as a travel router and need to access captive portal, I needed to upgrade to 4.6.

1 Like

I had to downgrade to v4.5 it is pretty stable. I tried the version 4.6 and after several weeks, I noticed some VPN drops (OpenVPN Client). And the most important thing as someone previously said, the v4.6 has issues with WIFI, it just stops working and if you disconnect and reconnect again to the network it starts working again, I couldn’t download a 10GB file, or even load a page, that made me downgrade, I guess it has something to do with the 2.4G issue people is talking about, I’m not sure because it’s supposed to get slow only but it didn’t work at all. I will try the next beta when released for sure @alzhao

Update: Now that I’ve physical access to the device, I can confirm that this bug is introduced by 4.6.0-r2-2.1-13.20 update. rolled back to the alpha 4.6.0 fixes the problem


Hello, 4.6 beta issue:

MT3000 in repeater mode, uplink to an ATX1800, after a while MT3000 reports detecting a radar and wants to change channel, but can’t as it’s set up as repeater and shuts down the interface. No automatic retry, have to reboot it.

Now, am in a very remote area, there is no radar in at least a 100km radius, ATX1800 does not detect any radar, MT3000 catching some other interferences or a bug?

When in repeater mode, should it just turn off radar detection and trust uplink?

Here the logs:

Thu Feb  8 18:50:26 2024 daemon.notice hostapd: wlan1: DFS-RADAR-DETECTED freq=5620 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5610 cf2=0
Thu Feb  8 18:50:26 2024 daemon.notice hostapd: wlan1: DFS-NEW-CHANNEL freq=5180 chan=36 sec_chan=1
Thu Feb  8 18:50:26 2024 hostapd: wlan1: IEEE 802.11 driver starting channel switch: iface->freq=5620, freq=5180, ht=1, vht_ch=0x0, he_ch=0x0, eht_ch=0x0, offset=1, width=3 (80 MHz), cf1=5210, cf2=0, puncturing_bitmap=0x0
Thu Feb  8 18:50:26 2024 daemon.notice hostapd: wlan1: CTRL-EVENT-STARTED-CHANNEL-SWITCH freq=5180 ht_enabled=1 ch_offset=1 ch_width=80 MHz cf1=5210 cf2=0 is_dfs0=4 dfs=0 puncturing_bitmap=0x0000
Thu Feb  8 18:50:27 2024 kernel: [34595.797892] ieee80211 phy1: channel context reservation cannot be finalized because some interfaces aren't switching
Thu Feb  8 18:50:27 2024 kernel: [34595.808429] wlan1: failed to finalize CSA, disconnecting
Thu Feb  8 18:50:27 2024 kernel: [34595.813986] br-lan: port 2(wlan1) entered disabled state
Thu Feb  8 18:50:27 2024 daemon.notice netifd: Network device 'wlan1' link is down
Thu Feb  8 18:50:27 2024 daemon.notice hostapd: handle_probe_req: send failed
Thu Feb  8 18:50:27 2024 daemon.notice hostapd: CSA failed (wlan1 was stopped)
Thu Feb  8 18:50:27 2024 daemon.notice hostapd: wlan1: AP-DISABLED

Also 4.6-beta2 in pretty unstable, I guess devs just rushed it before holidays… :sunglasses:
4.6-beta1 seams to be more stable.

Did you notice this? And I also lost DNS connection a few times, after a few days, that’s why I downgraded. Both 4.6 versions seems to have that issue but especially the beta version

I didn’t pay much attention to the dns when it was having issues. But now that I’ve set it to reboot at 3am in the morning I haven’t have any issues. Been running with WireGuard and AdGuard for the past few days without issue.

1 Like

It’s pretty clear there is an underlying firmware issue, best to wait until they release updated firmware with fixes and the new open source driver.

1 Like

Don’t know will help or not, the 23.05.2 version of normal openwrt does not seem to have the buggy connection issues. Hopefully the 4.6.0 can be based on stable 23.05.2 instead of 23-snapshot


There are some package compatibility issues .

Could you show us more detail?

1 Like

Hello developers, based on openwrt 23.05.2 stable release date ?

Beware of the 4.6.0 snapshot from the Despite it also being version 4.6.0 like this with OpenWRT 23.05 and opensource mt76 wifi drivers it is in fact a 21.02 version with MTK SDK based drivers. Learned it the hard way when upgrading from earlier 4.6.0 version from this thread to the latest snapshot from the website and now I cannot connect to the device via GoodCloud. Will need to investigate on-site some other time as I use it as a remote Access Point.


Indeed… what a mess, it’s not 4.6 …

1 Like

I would also like to know the answer to this. Just got stuck trying to get travelmate plug-in working and it sounds like a firmware release based on OpenWrt 23.05.2 would get me unstuck. Thank you.

can we get an update!?

1 Like

Yes it has been a long time coming…

1 Like

I’m very sorry that keeping you wait so long. The open source WIFI driver have a 2.4G issue. that we can’t fixed it right now(Same to MT6000). So we suspend the new version.

1 Like

That’s unfortunate as 4.6 beta1 fixed all 5G issues and actually run pretty stable, I personally don’t care about 2.4G.

So what is the path forward and why is the snapshot listed as 4.6 but is based on the old OpenWrt 21 ?

Super confusing…


This device needs to be recalled then, can I organise a refund, the device simply does not work.

1 Like