MT300N-V2 wireless client issues

I’ve been trying to use my device as a Repeater Bridge with no luck. On the stock firmware following (404 Page not found - GL.iNet) online instructions I’ve tried both WDS and WISP but the major issue is the SSID dorp down doesn’t show any SSIDs and when I try to hand try it in the js clears out the value (guess it’s not a combobox?).

On the other hand using openwrt clean following their realyd instructions I get a list of SSIDs but when I try to join one I get (/usr/lib/lua/luci/i18n.lua:42: bad argument #1 to ‘format’ (integer expected, got nil))

Which when I look around I find this GL-MT300N-V2 Join Network : Wireless Scan problem .

I suppose I could follow their idea and compile my own image of openwrt. Any ideas?

1 Like

The article is a little bit old. Now you can set up bridge using the stock firmware.

I suggest you upgrade to firmware v2.27 from GL.iNet download center

For MT300N-V2, WDS works for all kinds of AP, because it uses its own layer 2 technology. So pls set up WDS bridge. NOTE: please DO NOT set up IP address when you set up wds.

I’d certainly try that but GL.iNet download center 2.264 is the latest in the repo. Is it possible you could drop the direct link here?

I have tried that one already with mentioned results. I also tried the 2.26 and again same results.

Here is the correct url

alright so the ui is responsive but it’s not showing any of my SSIDs.

So I just tried picking a SSID and changing the ssid config at /etc/config/wireless and /etc/wireless/mt7628/mt7628.dat

That didn’t work either. And now the web interface is unresponsive…

Is there perhaps a cli command or config file edit I am missing?

Can you not modify the file directly and just reset the firmware or reflash using uboot?

I also have a problem using MT300n-v2 as wifi client.
I have tried all firmware versions even 2.27 testing one - but I can not configure it to connect to other wifi network as client. In LUCI it even not able to scan wifi networks, any guess when MT300N-V2 will become usable?

When using the default UI, can you get a list of wifi when setting up repeater?

When set up, are you using WISP or WDS?

For mt300n-v2 wireless, not support luci.

Yes, I see list of wifi with defaut UI, but if I go to Advanced settings → in Luci - not.

The problem is I do not want to use it as repeater, I want to connect to wifi as a client and not be AP itself.
All that worked pretty well with MT300N but now not, Luci adds to the router flexibility unachieveble with default UI, and I really beleive many of your buyers want such router to have such advanced settings.

Can you set up repeater and just disable AP?

Yes, it works this way, and if I need more advanced settings like setting manual ip for wireless client or firewall settings - I can do it
only via Luci, but if need to change wireless settings - I can use only default UI. Thats like going home only via window, and exiting only via doors. Anyway, thanks so much for advice!
Really hope will come fully usable again for this model.

Hey :slight_smile:

This post is “well funny” - I spent like 2 hours, at like 2am this morning, flashing, configuring, reflashing, reconfiguring, trying to get Wifi Client to work - I thought I was being really dumb, but, as it turns out, I’m not dumb at all, and this feature is broke or non-existent…

Irony is that I bought this like 2 days ago to use as wifi client linking to the shared home router, to route and firewall traffic before it hits my internal PFSense and IPFire routers… wifi sucks, and I’d sooo much rather cable the connection, but its all I got…I was trying to replace my existing wifi bridge with a better solution…

Hope the Wifi Client “feature” can be fixed or implemented soon, with firewalling and NAT on wifi connection please, so I can actually use the device… I might try a different approach, but that might mean I end up still needing this solution, so will have to buy a second one aswell… and seeing as I can’t find any better devices than this one, it would be super awesome if it worked, cheers !!! :slight_smile:

I’ll worry about LAG’ing the LAN and WAN ports together with my switch after that to try to increase the 100mb cable connections compared to the Wifi like 300mb connection…

Cheers !!! :slight_smile:

hey :slight_smile:

Ok, so, I just tried the 2.27 testing firmware…mmm…looks like any wifi in Luci is broken…I can’t even get the list of wifi networks to show - at least that worked in the 2.26 firmware, even if they wouldn’t connect…mmm…sorry…getting really bored with sucky wifi under linux now… this S shouldn’t be this difficult… I really thought this box was gonna be good… having 2 different front ends complicates matters, and I don’t really know where I’m spose to be looking for what…all I want to do is select and connect to a wifi box, and decide which ports are blocked or forwarded to where… why is it sooo hard to find a device that does wifi with a firewall on the wifi… or am I just dumb and doin things wrong ???
sorry sounds like a rant…wasn’t spose to be a rant…think turned into a rant…I don’t send back cheap boxes, and I generally don’t buy those boxes or from those manufacturers again, ever… I really hope this gets sorted soon, cos I really want to like this box and manufacturer…I almost bought a V1 a few months ago…perhaps I should’ve… :slight_smile: whats that - Win10 is an upgrade…wot, like Vista was an upgrade… more like a downgrade ??? :slight_smile: hope the V2 is an upgrade, cos this looks like a downgrade for every upgrade so far… :slight_smile:
I didn’t realize this was gonna be like it was when I was buying my old BTC Miners - pre-orders, beta testing, problems, etc… :slight_smile:

Cheers !!! :slight_smile:

hey :slight_smile:

Update - hopefully client connections will be sorted soon - I have no official or unofficial info from anyone to share tho, sorry… Anyway, I’ve just bought a “Vonets VAP11N-300 Wireless Mini Wifi Bridge / Repeater” - hopefully setting this up in bridge mode and plugging its ethernet cable into the WAN port of the MT300N-V2 will be a “temporary” solution to my problem… that way I get both client connection to home router, and firewall using this device…is advertised as 300mb, but think its only 150mb wifi…should be delivered tomorrow… hopefully it will work… hope helps… :slight_smile:

VAP11N-300 will prob need to be powered seperately as the MT300N-V2 prob won’t push enough power through USB for it to work…

Cheers !!! :slight_smile:

I have the same issue, and really need a proper fix for it - I made a post about it a few months ago (here), but didn’t get any reply so I gave up on it and went back to using the original MT300N. But it doesn’t seem to be possible to buy that model anymore, so now I’m stuck :frowning:

Personally I don’t actually need it to work from LuCI, but I do need it to be possible to scan for and to connect to WiFi networks from command line scripts. That would normally be done via uci commands, so if that were working, then I’m sure LuCI would too. But if there is an alternative way to interact with the WiFi drivers from the command line, that would be fine too.

You can use iwinfo to scan wifi.
But this doesn’t mean you can use Luci. Luci needs extra library.

I need the Luci interface because the network I want to connect to as a client has PEAP protection. If PEAP were integrated standard in the GL-Inet interface I would be totally fine! So the lack of the scanning-feature in Luci is unlucky to me too…
Works fine on my AR750, but i didn’t upgrade this one to 2.7 reading all of this.

Sorry for mt300n-v2 doesn’t support EAP.

sorry for this late reply, but could the ar300m do this, eap?