MV1000 Brume setting lan1 with tagged vlans only and creating 6 more vlans

If I ask this questions as precise and politiely as I can hopefully someone will take the time to answer it.

I’m going to compare how I did it with the ar750s as to what I need on the brume
I set my network as vlans as such on my ar750s in /etc/network below and picture of switch settings in luci

when I connect my last lanport on my ar750s it is connected to an 8port 8021q managed switch where ethernet-port8 on my managed hub is tagged for vlans1-7.
ethernet-ports1-7 on the hub are each assigned untagged ports resptively 1-7 with pvid’s respectivcely 1-7.
I know the brume has interface wan, lan0, lan1 and usb0.
i wish to achieve the same setup with the brume. I know the ar750s has the wan on vlan2 so I’m not looking to achieve that but rather another vlan for it.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd12:xxxx:xxxx::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.8.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t 2 3t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 1 3t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0t 3t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '0t 3t'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '5'
	option ports '0t 3t'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option ports '0t 3t'
	option vid '6'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '0t 3t'
	option vid '7'	

config interface 'network3'
	option ifname 'eth0.3'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option macaddr 'XX:XX:XX:XX:XX:03'

config interface 'network4'
	option ifname 'eth0.4'
	option proto 'static'
	option ipaddr '192.168.4.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option macaddr 'XX:XX:XX:XX:XX:04'	

config interface 'network5'
	option ifname 'eth0.5'
	option proto 'static'
	option ipaddr '192.168.5.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option macaddr 'XX:XX:XX:XX:XX:05'

config interface 'network6'
	option ifname 'eth0.6'
	option proto 'static'
	option ipaddr '192.168.6.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option macaddr 'XX:XX:XX:XX:XX:06'

config interface 'network7'
	option ifname 'eth0.7'
	option proto 'static'
	option ipaddr '192.168.7.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option macaddr 'XX:XX:XX:XX:XX:07'

@hansome Please help with some Suggestions.

ive looked here,
https://openwrt.org/docs/guide-user/network/vlan/managed_switch
and here
https://openwrt.org/docs/guide-user/network/vlan/switch_configuration

I’m okay with vlans starting at 100 I just cant grasp how to configure and map all the vlans to lan1 port as all tagged.

MV1000 vlan is not managed by swconfig, so “switch_vlan” part is not needed as ar750s.
The following network config should fit your needs.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd72:bff2:c413::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan0 lan1 lan1.2 lan1.3 lan1.4 lan1.5 lan1.6 lan1.7 usb0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option hostname 'GL-MV1000-001'
        option ipaddr '192.168.88.1'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'
        option hostname 'GL-MV1000-001'
        option metric '10'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

config interface 'lan0'
        option ifname 'lan0'
        option macaddr 'e4:95:6e:40:00:02'

config interface 'lan1_2'
        option ifname 'lan1.2'
        option macaddr 'e4:95:6e:40:00:02'

config interface 'lan1_3'
        option ifname 'lan1.3'
        option macaddr 'e4:95:6e:40:00:02'

config interface 'lan1_4'
        option ifname 'lan1.4'
        option macaddr 'e4:95:6e:40:00:02'

config interface 'lan1_5'
        option ifname 'lan1.5'
        option macaddr 'e4:95:6e:40:00:02'

config interface 'lan1_6'
        option ifname 'lan1.6'
        option macaddr 'e4:95:6e:40:00:02'

config interface 'lan1_7'
        option ifname 'lan1.7'
        option macaddr 'e4:95:6e:40:00:02'



thank you for your response. it’s greatly appreciated. now since I’m new to vlans with this device i hate to say i’m still trying to understand.

I’m seeing

it seems to me(even though I think im wrong but have to ask) that the settings is running tagged and untagged packets on lan1. in my reading it was saying to not run tagged and untagged traffic on same port in general.

Maybe you should remove lan1 in lan interface ifname, ie

option ifname ‘lan0 lan1.2 lan1.3 lan1.4 lan1.5 lan1.6 lan1.7 usb0’

You can have a try.

perhaps changing lan1 to lan1.1 because I still want access to vlan1 through the switch on port1 of the switch.