No wi-fi calling on t-mobile since installing spitz AX GL-X3000

I have found on several forums that WiFi calling needs to have WMM turned on in the routers QOS settings. There is no option to enable WMM or QOS services on the GL-X3000. Some router manufacturers even have an option when setting up the cellular connection to “enable WiFi calling over T-Mobile” so apparently their is a fix for this issue and it’s a known one with other manufacturers as well. This seems to only be an issue when connected to 5G SA(Standalone) towers. No need to reply with “mine works” if you are connected to 5G NSA networks or a combination of LTE networks.

Is there a plugin that the X3000 can use to enable QOS and WMM that will work on this router?


WMM may not be necessary as the OP didn’t touch WMM settings.

There seems to be a proper fix for this now without having to use wireguard. Now the programmers just need to implement a fix for this in a future firmware.

1 Like