Setting Up Opal as WiFi USB Disk Drive Access

Trying to figure out how to set up my Opal as a device to connect my Windows machine to a USB drive in the Opal port with the Opal connected to my LAN only via WiFi, as below. I want to use the USB drive for nightly backup, in a remote part of my house where there isn’t any ethernet or USB connection, hence the WiFi connection to the Opal.

[Windows 10 PC] <> [Main Router] <> [Opal - USB Port] <> [USB Drive]

  1. First, will the Opal support this?

Second, connecting to the Opal directly to my computer ethernet port temporarily for configuration, I went to APPLICATIONS | File sharing. The Opal said I had to go through an install process of some sort for the File Sharing, but once I did successfully, I got a screen with three slide switches, but no annotation at all as to what they were for.
2) Is this what I should have gotten?
3) What are the three slide switches for, and how should they be set?
4) What mode should the Opal be in for this application? Access point?

Should work fine.

You need the USB drive inserted and note that it’s not hotplug so you’ll need to insert USB drive and reboot before configuring.

Page should look like this:

Should work in extender mode.

1 Like

limbot, Thank you, but unfortunately, rebooting the router hasn’t really fixed the issue with the blank annotations, except I can now see the Current Directory set as /mnt/sda1. Where you show “Share via LAN”, I just have white blank space. Same for the next two. I’m not seeing an option for me to attach a screenshot to my message or I would here. Probably because I’m a new member to the forum. Any additional suggestions are welcome. Thanks again.

What version of firmware are you running? . Perhaps try upgrading to latest that can be found at
Also perhaps try a different browser or a incognito/private tab.

(you should be able to snip/capture./copy a screenshot and just paste into your reply.)

I get the blank File sharing page also, which is a bug. I just use LuCI for file sharing, which is much more flexible:

Access Point mode requires an Ethernet connection. You should use Extender mode:

I do not work for and I do not have formal association with GL.iNet

limbot, I am using the FW version which came with it, 3.206, which is also the only version which is available from the GL-Inet download site. So, I don’t see an opportunity for the FW rev to be a problem, unless the issue was introduced into their current offering. Also, your suggestion of another browser worked. With Edge, I see the switch annotation text. I had been using Chrome. With Chrome, no switch annotation text. Success! Thanks a mil.

wcs2228, Thanks for the LuCI suggestion. I will look into it.

So now, with using Edge instead of Chrome, I’ve got the File Sharing page looking good. The Current Folder dropdown is showing all the folders on the thumb drive, so it is seeing it. Now I can’t get to the files on the USB drive through Windows. Currently, I’m cabled directly from the computer to a LAN port on the Opal. Will deal with wireless later. So with file sharing turned on in Opal, how do I get to the file system on the thumb drive in Opal’s USB port via Win 10? I’ve tried using the explorer with address \, the Opal’s ip address. No luck.

I’ve also tried opening a Run window, typing \192.168.8/1, and get an error message about the share needing SMB1 protocol which is unsafe, and “your system requires SMB2 or higher.”

I can ping fine via a CMD window.

Error message which is referred to in previous post.

Ok I don’t have Opal but in my AR750S i did this to solve this problem .

I uninstalled via Applications>Plugins all related to samba/samba36.
Of course that will be unavailable in GL.inet Admin Panel but available in Luci for config.

Make Update in Plugins
Samba 4 is SMB2 compatible

Install luci-app-samba4/samba4-admin/samba4-libs/samba4-server. Some are yet installed when you install luci-app-samba4.

Then go to luci > ( > Services > Network Shares and configure your USB Disk.
My config as example

I forgot to delete “casita” from allowed users… don’t put anything there if all users have permission to access shared files and check Allow Guests

SMB V1 is not considered secure, so it has been removed in Windows by default. You can re-enable SMB V1 it by installing the Windows feature Simple 1.0/CIFS File Sharing Support, but this is not recommended:

Samba36 actually supports SMB V2, as does Samba4 which also supports SMB V3. I only have Samba36 installed on my routers for SMB V2.

I do not work for and I do not have formal association with GL.iNet

I don’t have an Opal, but I have file sharing on my travel routers. Under This PC, “add a network location”, add \\\GL-Samba

Mango 3.212 snapshot
Beryl 3.211 stable
Not affiliated with GL-iNet–just a user

David, I was able to uninstall samba36-server. But I don’t see anything available for samba4 in the GL-iNET config panel or the Luci config panel. I only see luci-app-samba, which is the samba36 system.

If I use the app search utility to search on ‘samba4’ it finds nothing.
There is something called “Download and install package:” with a blank field next to it. Perhaps there is a link to the samba4 package which could be downloaded into the Opal, but I don’t know it. Do you?

wcs2228, When I go into the Opal’s File Sharing page, it forces me through an INSTALL process, which installs samba36. I had done that prior to getting the error message about SMB1. You indicated samba36 supported SMB V2 which agrees with what I’ve seen online. So I wonder why windows is saying it thinks the connection requires SMB1.

You have to make a modification to the /etc/samba/smb.conf.template file, as described in the link I provided above.

You may have to make the same modification to the */etc/samba/smb.conf file.

I do not work for and I do not have formal association with GL.iNet


I also tried with \\mnt\sda1 which the File Sharing page shows as the current directory of the inserted USB drive. It gave me the same error message.

Under This PC, I also tried mapping to the drive, and got the same SMB1 error message I received before.

It is better to install the luci-app-samba package and use the LuCI Network Shares page as I and David suggested above. LuCI allows you to name the share to what you want (do not include blanks in the name), whereas the GL.iNet UI only has the default name of GL-Samba.

I do not work for and I do not have formal association with GL.iNet

Did you click Actions > Update Lists?
This updates all packages/plugins available for the router.
And then you can Search in Available by using Filter and samba4.

I don’t know if the Opal 3.206 firmware already has the samba4 plugin.
On my AR750S I have 3,211 firmware.

@David No, I did not try that. I was going to tonight at your suggestion, but the Opal was acting flaky. I am giving up on it. Too many problems with this, many of which I haven’t even mentioned. It shouldn’t be this difficult to get it to host a USB drive via WiFi. I am returning the unit to Amazon.

1 Like

OK I don’t know Opal.

Thank you for your suggestions and help. I did learn some things. As I said in one of my posts, “It shouldn’t be this hard.” I think I was right. I never could get the Opal to allow me access to the USB shared drive. I returned it to Amazon

Today I went out and bought a used Asus RT-N66R. While there was a a bit of guesswork there as well, it was not insurmountable. I was able to get it set up and running without any bizarre mysteries. No help required from any outsiders accept one YouTube video which cleared up what the name of the network device should be as seen by Windows. The user interface was MUCH more polished and intuitive. The WiFi wasn’t acting flaky, there one minute, gone the next. Internal web pages weren’t missing text. I was able to get access to the USB drive in its USB port and read and write from/to it through a mapped network drive in Windows 10. It took me about 3 hours of effort, more than I would have liked, but doable and acceptable. There was no step-by-step guide in the manual for doing it, but the router’s internal web page was intuitive enough that I could figure it out basically on my own.
I was wondering if it was me or the Opal which was at fault here. I can honestly say after the experience with the Asus, I can point the finger less at my self than I had been earlier while working with the Opal. It may be a great little device for the right application, and it may even be able to do what I was wanting it to do, but their firmware developers have “opportunities for improvements” in my opinion.

Again, thank you all for your assistance. It is appreciated.

1 Like