Trouble with mt300NV2 as wireless bridge

My end goal: I want my NAS in another room without having to use a cable through the wall or through my apartment.

Problem: I have the mt300nV2 that i purchased for another use case. Is it at all possibel to do a wireless bridge between my ISP-router and the mt300nV2 so that my devices, that are connected to the ISP-router can still “talk” to the NAS connected to the mt300nV2 via cable?

Use extender mode. This should do what you’re asking.


Thank you for your suggestion.

I am thinking, that there must be more to it than that. I have tried to enable extender mode, but the client connected to mt300 via RJ45 is still getting ip on different subnet and has no internet.

I can only get internet working using repeater. But then again, the client is on different subnet.

Any tips?

Extender mode on the GL-MT3000N-V2 should work in this application. What are the IP address and Default Gateway IP address that the client gets when connected to the router’s LAN port via Ethernet?

You can also try in Router mode to port forward both TCP Port 139 and TCP Port 445 from the WAN side to the LAN IP address of the NAS.

The GL-MT300N-V2 has only 2.4GHz wifi and may not provide much NAS speed.

I do not work for and I am not directly associated with GL.iNet


Occams razor :slight_smile:

If you are getting an IP address in a different subnet (I’m assuming you’re getting 192.168.8.X subnet on the Mango side?), then extender mode is not being setup properly.

In extender mode, the Mango should get an IP address from your primary router via DHCP and as such be in the same IP subnet. You can of course use a static IP on your primary router to set a static IP .

If you attach to either the LAN or WAN port of the Mango (the WAN will be a LAN port in extender mode), then if it’s using DHCP it should pick up an IP in your primary router subnet.

Yes, getting 192.168.8.X

I cannot see, how I should set it up differently.

After resetting it, I simply go in to the network mode settings, choose extender and then connect to the wireless network, that I want it to extend. Still get the 192.168.8.X, though.

After going through these steps, it does seem like I am in extender mode, based on the menu items I have available.


So, it’s only clients connected by RJ45 that gets the subnet from the Mango. Wireless clients work fine on same subnet as ISP router.

However, it seems that the Mango automatically port forwards to the Client on LAN-port. My mistake was trying to set this up via a computer connected VIA LAN and not understading how it actually worked :slight_smile:

Problem solved.

1 Like

I think the wired device should get subnet from ISP wifi. You need to disconnect and reconnect cable so that the IP refreshes.