Spitz AX "Sim card not registered" problem

Can someone please help. I have no internet, as it says "SIM card not registered". Although I have the green icon for internet, in another device the SIM works.

Why is the issue with the Spitz?

It's being used on the Three network in Italy.

And then sometimes the "SIM card not registered" disappears, but I still get no internet, only a few kB.
Very frustrating.
I put TTL to 65...

And SIM not registered is back.

Try AT command


To generate phone IMEI use something like this tool:

1 Like

Can you remind me where the AT commands are hidden in the GL UI please? I can't seem to find it anymore :sweat_smile:

@blancmange maybe this will help?

But use change imei command, not command from article

1 Like

@getmyfeaturesback Jesus that seems to of worked, I see my new "Galaxy S21+" IMEI number, and internet is working! I'll monitor for a couple of days then mark your post as solution! :pray:


@blancmange some ISP blocks internet if it is not phone. They detects it via IMEI and TTL. Moreover I don’t recommend to use default IMEI for privacy reasons.


@getmyfeaturesback thank you so much, such a simple fix, I thought TTL of 65 was enough, didn't realise IMEI number was also important, this issue should kind of be more clearly made visible.
@alzhao next issue, when I leave data coverage area, and come back into data coverage area, it connects again, but doesn't give internet. GUI looks good, I have excellent coverage, but the only way to get internet working again is to reboot the router, can I pm you my logs please?

Does you sim roam between different carriers?

It shouldn't, it's the Very data operator in Italy, that uses the Three network. It just changes between 4+, 4, and 3...

Can you update the firmware of the modem according to

Here is the newest (as of this comment post date) firmware for just the modem and the simplest way to update it directly from a support person from GLiNet directly from another thread that they were helping me with. [quote="ywp, post:10, topic:37128, full:true"]
Access the background of the router using ssh

ssh root@

  1.mkdir /firmware
  2.cd /firmware
  3.wget https://fw.gl-inet.com/download/RM520GL-modem_firmware/RM520NGLAAR03A03M4G_01.201.01.201.zip 
  4.unzip RM520NGLAAR03A03M4G_01.201.01.201.zip -d RM520NGLAAR03A03M4G_01.201.01.201
  5.QFirehose -f RM520NGLAAR03A03M4G_01.201.01.201


1 Like

Thanks @fastcompjason I managed to update the modem firmware following these instructions. The zip file didn't download correctly at first, I had to use ChatGPT to help me delete the zip file then I could download it again. All good. Updating the modem firmware and changing IMEI I see a major major improvement with the Sptz, I should of done this month's ago!

1 Like