Spitz GL-X3000 constantly crashing

Sometime after the 4.4.5 router firmware release, my GL-X3000 began to randomly crash. Since then, it has increased in frequency to several times a day, sometimes only staying online for a few minutes before crashing again. The record longest it has stayed online is only 36 hrs in the last 2 months.

this is on the t-mobile network

What I’ve tried:


  1. sometimes it stays online for a few hours, then freezes and reboots
  2. once it has crashed, it usually crashes a few more times in quick succession, then stays on for a few hours
  3. when it crashes, it will do one of the following before cycling:
    a.) only power light and 1 signal bar will be lit
    b.) only 1 signal bar will be lit
    c.) no lights at all
  4. sometimes it never comes back from crashing until i reset the power by unplugging
  5. half the time when it reboots, it has switched to the empty sim slot 2 and will not switch back until i log in and manually switch it
  6. there are no Crash Logs

The instability has become such a major problem since I work from home and never know when the next crash will occur.

I now believe this must be a hardware failure of some kind, and am now going to try flashing the original modem and router firmware as a last ditch effort since last year was the last time I can remember any stability.

Have you made any changes/modifications to the DNS settings? You are experiencing the same exact issues I’ve had in the past. My Mobile carrier has been working on local towers which has been a major factor.

Thanks for the feedback, I hadn’t thought much of DNS so I’ve usually let it come from the carrier.

Last night I did try:

  • set DNS manually to cloudflare non TLS
  • disable all wifi radios

it crashed and rebooted after 12 hours.

DNS could be the cause for a general connectivity issue, but it shouldn’t affect the system to the point of hard crashing/system failure

I ended up flashing the openwrt snapshot build to the router and haven’t had any crashes since. This means, thankfully, no hardware issue just buggy software. support for gl.inet gl-x3000 was only recently added so snapshot builds are the only option until the next official openwrt build is released. since snapshot builds only exist for 24 hours (midnight probably), you’ll want to keep a copy of the repo (in the instructions) to install software, etc, after that time period.

  1. download openwrt snapshot (squashfs-update) for glnet_gl-x3000.
  2. install via uboot
  3. download via rsync to usb (ext4 formatted):
    1. download kmods. the latest will likely work, but confirm the version via ssh to router and examine /etc/opkg/distfeeds.conf.
    rsync --bwlimit="8M" --info=progress2 --del -r -t -v rsync://rsync.openwrt.org/downloads/snapshots/targets/mediatek/filogic/kmods/{$VERSION}/ ./kmods/
    1. download core packages
    rsync --bwlimit="8M" --info=progress2 --del -r -t -v rsync://rsync.openwrt.org/downloads/snapshots/targets/mediatek/filogic/packages/ ./core/
    1. download the main repo
    rsync --bwlimit="8M" --info=progress2 --del -r -t -v rsync://rsync.openwrt.org/downloads/snapshots/packages/aarch64_cortex-a53/ ./aarch64_cortex-a53/
  4. mount usb to /tmp/repo
  5. update opkg feeds (/etc/opkg/customfeeds.conf)
    src/gz openwrt_core file:///tmp/repo/core
    src/gz openwrt_kmods file:///tmp/repo/kmods
    src/gz openwrt_base file:///tmp/repo/aarch64_cortex-a53/base
    src/gz openwrt_luci file:///tmp/repo/aarch64_cortex-a53/luci
    src/gz openwrt_packages file:///tmp/repo/aarch64_cortex-a53/packages
    src/gz openwrt_routing file:///tmp/repo/aarch64_cortex-a53/routing
    src/gz openwrt_telephony file:///tmp/repo/aarch64_cortex-a53/telephony
  6. install packages
    opkg update; opkg install luci luci-ssl kmod-usb-net-cdc-mbim umbim luci-proto-mbim kmod-usb-serial-option picocom
  7. run picocom commands:
    1. set the modem to MBIM protocol
    2. query the modem interface mode. 1,0 is pcie and 0,0 is usb. only usb works so it should be 0,0
    3. if the previous output was 1,0, set the mode to usb
  8. reboot
  9. in openwrt ui, add modem interface with:
    • Protocol: MBIM, set APN, etc
    • firewall to wan ruleset
  10. save and apply
  11. restart modem interface and internet should be up
  12. enable wifi if needed


1 Like

Thanks a bunch! I have been frequently checking the Openwrt repositories for a release that supports x3000.

Thank you for sharing the step-by-step details as well, it definitely helps!

Have you tried to restoring GL firmware after installing the plain one? I guess it should be through Luci?

@SpitzAX3000 no problem! yes, you can definitely restore the stock gl.inet firmware via uboot. it may work through luci, but i haven’t tested that.


Besides the known gl bugs, have you noticed any speed improvements for the 5G connection?

I’d have to estimate the stock firmware since I didn’t keep records, but:

firmware down (Mbps) up (Mbps) ping (ms)
gl.inet ~280 ~70 ~60
openwrt 340 85 20

the biggest difference i’ve noticed is latency. i don’t recall seeing much below 60 or 70 with the stock firmware, whereas, i’m consistently getting low 20’s now. i don’t have anything else running though, so this is a very minimal installation without additional services taking up cycles. YMMV

Those numbers are…shocking. Especially latency.

Thanks for sharing the stats! I am flashing my device this weekend and I will be posting any findings as well.

1 Like

Looking forward to seeing what you come up with. Thanks for taking the leap.


Can you please run these commands after installing the vanilla Openwrt? Thanks!

cat /proc/mtd
fdisk -lx

I am concerned about the structure changes when I want to revert to the GL stock firmware.

Another question: the link you provided has a sysupgrade image. Why did you install it using Uboot instead of Luci?