Constantly Loosing Cellular Connection on Spitz x3000

About a month ago, at random intervals wether it be a couple days, hours, weeks my X3000 will just cut off from its internet connection. And its caused a lot of problems from all devices loosing internet connection. Including my child not being able to call us during a hellish nightmare of a emergency, to the security system not catching who or what happened to packages, the thermostat not being set correctly. And the house becoming freezing, to a whole host of crap.
Ive seen others with similar posts but those are going back months or years, and always seems to be fixed with a firmware upgrade. Well im on much newer firmware than they were and im a lot farther in the future so this really shouldnt be happening! Im running 0406release1, On tmobile, apn and TTL 65. My identical spitz x3000 in my semi truck NEVER has this issue, maybe occasionaly a weak signal but i just perform a reboot on the truck Spitz and that fixes it. Ive spent hours playing with my home (problem modem) with my home x3000 and it seems if i (just discovered this) if abort the connection and retry it then it will connect. I cannot do this from afar, with the android app and goodcloud. What is the fix, and why is this still a issue apparently, after being previously stated to upgrade your firmware to fix,(which I cant even check if there is a upgrade available since the upgrade page has no button to force a check for new firmware,and im pretty sure im on the current release as previously mentioned)

Anyways, here is a pastebin of my log so it doesnt take up the whole page.
I would really appreciate a step by step fix for this. Its really been a nightmare.
Thank you in advance - Locked Paste password is “spitz” no quotes

Two things you can try:

  • upgrade the firmware if the cellular modem to the latest version A8 - not the device one.

  • kill the multiwan and wan tracking processes.

Please report back whether it has been more stable.

I don’t know how to accomplish that unfortunately

I think I have posted this half a dozen times this week - glad it is handy lol.

I have my Netgear orbi rbr750 mesh router/2 satellites set to AP mode and hooked to the 2.5g port, will any of these suggested fixes mess with that?

hello, Looks like a problem caused by network acceleration, can you turn off network acceleration and test it?

Is this the latest version that I would want?


I have also seen these versions mentioned online:


Where is the best resource for staying up to date on the latest firmware?

The instructions for upgrading the Quectel modem appear to only be updating to RM520NGLAAR01A07M4G.

RM520NGLAAR03A02M4GA is not recommended
This is Quectel’s specially tailored version for Australian operators
You can choose to upgrade RM520NGLAAR03A03M4G_01.200.01.200


Longtime lurker. I created an account to reply here.

I was facing constant disconnect issues after the latest firmware update from gl-inet.

After downloading the modem version mentioned here, and upgrading the modem firmware through SSH to the router (P.S I used scp to copy the downloaded zip file from my machine to the router),

Using the latest modem firmware fixed all disconnect issues that I’ve been having on my Spitz!
I also turned off network acceleration and turned off Multi-wan cellular ping health check and that seemed to impact reliability as well.


1 Like

To expand a little bit more:

I’m using a Mac to connect to my Spitz x3000.
When I used these two versions, I still had disconnection issues:

  1. I opted for newest version RM520NGLAAR01A08M4G_01.202.01.202, released in February 2024, which is available in the original repository here
  2. After downloading this zip file, I copied it to my router like so:
scp -O ~/Downloads/$ root@$
  1. I ssh into my router and run the upgrade commands (like mentioned in this guide here):
ssh root@
unzip /$ -d /$FILE
cd /usr/bin/ && wget
chmod 775 QFirehose-mtk7981a-sha256-c0b944 && sha256sum QFirehose-mtk7981a-sha256-c0b944
QFirehose-mtk7981a-sha256-c0b944 -f /$FILE
echo 1 > /sys/devices/platform/11280000.pcie/pci0001:00/0001:00:00.0/0001:01:00.0/remove
echo 1 > /sys/devices/platform/11280000.pcie/pci0001:00/0001:00:00.0/rescan
gl_modem AT AT+QGMR
rm /$FILE* -rf

I haven’t yet run into disconnect issues with this latest firmware version, but if I still face those issues, I will report back with more information.


Because I am a glutton for punishment, I went ahead and also upgraded to this version after reading the release notes. There are a couple of CVEs (vulnerabilities) addressed in this release. My router is not critical and I might not be doing this if it were, so as always ymmv.

So this firmware update appears to generally be successful.

One issue I did notice is if I were to setup any VPN client, I would start to see loads of disconnect issues and would have to reboot the router to regain normalcy. If any of you who also upgraded to Feb 24’, could you see if you have this issue too?

Anyway, a VPN isn’t really that necessary for me. For now, just enjoying a better connection.

1 Like

RM520NGLAAR03A03M4G_01.200.01.200 Is there a problem with this version test?

I’m using RM520NGLAAR03A03M4G_01.200.01.200 now, so far so good. Haven’t experienced any random disconnects yet compared to the original RM520NGLAAR01A07M4G.

If the modem originally came with firmware RM520NGLAAR01A07M4G_01.201.01.201 (2023-03-27) - direct from GL.iNet, then what is the correct firmware upgrade path?

  • RM520NGLAAR01A07M4G_01.201.01.201 → RM520NGLAAR03A03M4G_01.200.01.200 (2023-07-25)


  • RM520NGLAAR01A07M4G_01.201.01.201 → RM520NGLAAR01A08M4G_01.202.01.202 (2024-02-01)

This is a great question and both are correct in a sense. The first choice seems to be acknowledged by at least one support person as a valid firmware to use. I have not seen anyone from support say you are good to install the newer firmware. As with all things, once you venture into an unsupported condition you should anticipate bad things may happen and react accordingly. So your call ultimately, just don’t cry to support if the new version breaks something or bricks your modem.

I tried RM520NGLAAR03A03M4G_01.200.01.200 and noticed a change in how SINR is reported in the Historical Signal Records page within the first 5 minutes of using it. Decided that there must be more issues that weren’t so visible, so I downgraded to RM520NGLAAR01A08M4G_01.200.01.200. Still having reboot issues so I’m looking forward to trying RM520NGLAAR01A08M4G_01.202.01.202 as suggested with the patch to fix reboot issues. I’d say that RM520NGLAAR01A08M4G_01.202.01.202 would be the one that Spitz and Puli users should stick with since it’s actually the latest firmware release specific to USA users.

1 Like

I upgraded to RM520NGLAAR01A08M4G_01.202.01.202 a few days ago.
I came from the Nov 23 dated firmware which supposedly wasn’t meant specifically for the US, but had fixed my connection issues with a Verizon Tablet SIM.
So far no issues, and I can connect to band 66. I had never gotten a working connection to that band with the previous firmware.
Seeing good speeds. Not enough of an increase to say there is an improvement there over the November 23 firmware.
Hopefully this firmware will prove stable and I can stop updating the router so often. Would be nice to get to a good, stable firware for both router & modem.

1 Like

You’re probably right about sticking to RM520NGLAAR01A*. Something I noticed about the R01 is that I could run AT+QMTUINFO. The R03 firmware would error when I run AT+QMTUINFO.

I went ahead and downgraded from RM520NGLAAR01A08M4G_01.202.01.202 (2024-02-01) to RM520NGLAAR03A03M4G_01.200.01.200 (2023-07-25).

RM520NGLAAR03A03M4G_01.200.01.200 (2023-07-25) appears to be more stable for me on TMO US. I lose connection from TMO towers on the 2024-02-01 firmware after about 30 min. I was on the 2023-07-25 firmware for the past week and have not experienced disconnections yet.