Using Tailscale Mullvad Exit Nodes on a GL.iNet GL-MT3000 (Beryl AX)

Just wondering if anyone has used Tailscale’s Mullvad Exit Nodes on a GL.iNet GL-MT3000 (Beryl AX). I know that Tailscale implementation is still in beta on the GL.iNet routers (only running version 1.32.2-dev-t). I’m also based in Australia and it’s not available here to test.

1 Like

To test tailscale stable version binary you can upgrade it manually for MT3000,

cd /tmp; curl -f -L -o tailscale_1.52.1_arm64.tgz
tar -zxvf tailscale_1.52.1_arm64.tgz
mv tailscale_1.52.1_arm64/tailscale* /usr/sbin/

Keep in mind the firmware version needs to be 4.5 at least.


I did note the typos and have updated the Tailscale version to 1.52.1. As I’m in Australia, I hadn’t tested the Mullvad Exit Nodes part. Because I don’t believe, it’s available as yet here.

Are you running firmware version 4.5?


Latest 4.5 snapshots have a bug:

On boot, 2G and 5G wifi APs come up as open network ( no password ) and with names:

1 Like

I didn’t reproduce the issue. Do you upgrade with keep-setting?

I reproduced the bug. I upgraded with keep-setting.

I tested again with today’s firmware upgrade from version 4.4.6.
There may be some config messed up in your old firmware.
Do you remember your previous version? You can export log for further debugging if needed.

Ah, I upgraded from the previous beta build of 4.5, not from 4.4.6


I had a similar effect here, however I noticed that these networks can be renamed, given a password and even disabled.

You can try turning them off, but they need to be set in the settings /etc/config/wireless

On my side, the issue is, I have 5G wifi AP configured but when the device is booted it sets up open AP with above names… After network restarting, the configured AP comes up.

Thank you guys. We’re looking into this.

Will it work if I amend this curl command based on the arm64 listed stable version here: or more correctly


cd /tmp; curl -f -L -o tailscale_1.54.0_arm64.tgz 
tar -zxvf tailscale_1.54.0_arm64.tgz
mv tailscale_1.54.0_arm64/tailscale* /usr/sbin/

EDIT1: OK, so I did that, it updated but still shows 1.52.1 in the admin page???

EDIT2: So I tried it again and got this error:
curl: (6) Could not resolve host:

I have little idea what I am doing but it seems a DNS issue. I have the Beryl AX connected to my Asus RT-AX86U via Ethernet Cable and set up as an AP via the Network Mode (using Webadmin, but why can’t GLi sort out an App option for that AP mode, why does it have to be done via Webadmin?!), so searching around I found (and issued) this:

sudo echo nameserver > /etc/resolv.conf

Which resolved the curl error and I could then run the commands above. My Router uses Cloudflare and, maybe it does not like that.

I had to then disable AP mode and reset the Router BACK to Router Mode to see if the Plugin Version had updated (Why can’t GLI allow the Tailscale App to run in AP Mode, is this a Tailscale limitation?).

In any case the version has now updated to 1.54.0.

1 Like

didnt work for me got this error after trying to insatll 1.54

root@GL-AX1800:/usr/sbin# ./tailscale
./tailscale: line 1: :s: not found
./tailscale: line 1: : not found
./tailscale: line 1: 4: not found
./tailscale: line 1: ELF@@8@@@@PPdd4K4KLMMHTHT7 Qtd4J]ML%: not found
./tailscale: line 2: can’t open ~CdN: no such file
./tailscale: line 2: SaD: not found
./tailscale: line 2: SbD
TBTCa@: not found
./tailscale: line 2: @hc_?T@@A@_OR: not found
./tailscale: line 1: : not found
./tailscale: line 2: xd: not found
./tailscale: line 3: syntax error: unexpected “)”

I recommend to use my tailscale update script: Script: Update Tailscale on (nearly) all devices

1 Like

same issue apparently new version is not working for some reason

What admon said :-). So much easier and neater.