X750v2 Spitz not enough space for plugins?


Just bought a X750v2 Spitz and have problems with installing plugins…

I first updated the X750v2 to the latest Sw version 3.201

Then I saw there is almost no space to install any plug-in??? Only 2MB starting from a factory reset configuration?
(I even tried the ‘Revert Firmware’ option that restores the factory default and removes all settings, applications, data,… Still same problem, only 2MB available for plug-ins…)

When I enabled the default plugins like ‘File Sharing’ and ‘Multimedia File Sharing’ this leaves 0% room for other plugins…???

I can’t even install Luci anymore.

Some help please… This cannot be normal…?
Would installing a microSD storage allow for more plugins space?

I also have a AR750-EXT Slate, and there I have ~89MB free with FW 3.201 and ‘File Sharing’, ‘Multimedia File Sharing’, ‘Luci’ plug-ins all installed, so something is definitely wrong with the X750v2 Spitz configuration???

Please help, what can I do to resolve this?

Got an answer through mail…

The AR750s Slate has 128MB Nand flash. X750V2 Spitz only has 16MB Nor flash.
Very unfortunate…

Question, if I would install a microSD, could I then install additional plugins on the SD-Card and increase the plug-in storage?
If yes, any guide available somewhere ???

Pls check this post How to expand the "disk space" of gl router by exroot?

exroot on 3.201 should be very easy.

Thanks, can you just confirm the following…

If I use exroot to use the SDcard as additional storage.
If the SDcard gets corrupted, will the device than still function? Or will it brick as it then looses it’s main storage?
Just want to understand, as there always is a risk that a SDcard or USB stick gets corrupted and surely don’t want to brick the router if that happens…

If the SD card is broken, you can remove the SD card and it will boot the normal system.

In my AR750 Creta

  • Save backup User config
  • Update Firmware resetting everything 3.201-402 (beta6)
  • Install Luci just right after updating

I had a 512Mb USB in it and also a 64Gb SD

I made /overlay in Luci>System>Mount Points

Select SD or USB Flash, in my case USB.



Easy after few tries.

Import User Config




could I get a bit more help on the setup in V3.201?
I formatted a 8GB MicroSD as EXT4…

Then went towards Luci>System>Mount Points

I see David mentioning to use /overlay, but unsure if this is correct??

So should I select use as ‘root filesystem’ or ‘external overlay’?
And what is the difference ???

I just did this too. use /overlay. Here’s my setup, before and after screenshots:

Thanks for the guide, David!

1 Like

Thanks indeed!

I now used an 8GB MicroSD and now have ample storage for whatever plug-in I would like to install…

Still unfortunate that GL-INET decided to only include 16MB NOR for the GL-X750, that should have been different!
(Especially with the V2 version where they had the chance to do so…)


you put extra space but the main system files will be in the router…when router space is full, all the additional files will be in SD, like new packages/plugins… You can remove SD (not recommended), some fonctions will have errors but not your entire router.

all your main system files will be in your SD. I don’t recommend this as SD may fail or corrupt.

I’m not an expert but I think this is how it works…

This is my config…one 2Gb SD for files and one old 512Mb USB for additional router software like plugins. AR750, no space after update 3.201 firmware.
mount points1



Ive tried to do the same thing as mentioned here but every time try to get this card to work it just doesn’t seen to show up in the system memory (this is the X-750 Spitz).

Here is a photo of my screen is there anything I’m missing here? Ive changed the file format to ext4 and it doesn’t work and on auto it shows as vfat both of these two ways don’t seem to make a difference even after a reboot.

Is there anything I’m missing here ? Any help would be great!

I had some difficulties doing / Overlay with 3.203_beta4 on AR750 / Crete, / Overlay was never going to sdb1 on reboot, but I finally did. I just had to format my 512Mb USB flash drive back to ext4. I think the partition was hidden or something.

I can not get this to work, it does see the SD and is mounted but it not showing under software the extra space. How do I format the card so it can be used, I did install the apps but still can not format. I did format the card as Fat on a windows system did that cause the issue?

Also made the same with 3.203_beta4 in AR750 and no problems.

I think you have to format in ext4 file system only. NTFS also is recognized for external drives for Samba and Network Shares but i don’t think for extroot.

thanks, yes that did work. had to get my son to format the SD card