Bricked AR300M, how to restore?

Hello,

I’ve managed to brick the AR300M by flashing the newly built openwrt image from openwrt-cc repo using sysupgrade (nand one). The moment I’ve executed sysupgrade it disconnected me from SSH and stopped working.

I have the NOR variant booted, but I am unable to push any images via uboot webui as it simply does not accept anythng it seems. As I did not soldered the pins, I have no way to connect the UART there.

How can I flash the NAND firmware from the NOR one?

Also, the Uboot’s that is used seems to be the pepe2k’s modification. It supposed to have the netconsole but it does not work. I even added the ‘ncport=6666’ uboot variable as well as set the stdin, stdout and stderr to ‘nc’ but that did not made the netconsole working. Any tips?

Now I’ve bricked it totally. The ‘sysupgrade -T *.ubi.img && sysupgrade -n *.ubi.img’ on the nand firmware from the gl-inet website did not only not fixed NAND, but I think it also crapped the NOR flash.

@alzhao, please help.

 

Take a look at this thread:

 

 

This will get you up and running. I thought I had bricked mine several times too but got it working.

Can you link me to a file that works for you? Because whatever image I try, it always get me ‘connection reset by peer’ when I hit upload instead of forwarding me to /flashing.html.

I have also AR150 and there it works without a problem, but on AR300M it does not.

oops,

First, when you upgrade the firmware when using ssh, just the one with .rar in the name, don’t use the one with .img. The .rar file is the correct one when you are in openwrt already. The one with .img in the name is used when flash using uboot webUI.

The uboot is not modified using pepe2k’s code, which doesn’t support nand.

What you could do is using uboot webUI: https://docs.gl-inet.com/en/2/troubleshooting/debrick/

Press and hold the reset button when you power on. Just hold the button. The LEDs will flash once per second and after 5 seconds, LEDs will flash quickly and uboot web is ready.

Then flash the .img file according to the guide above. But many people report AR300M uboot web has a problem with windows. If you do, please use Linux or Mac

@alzhao, when you said that it works on some systems but not on another I had a feeling that MTU is to be blame.

And I was right.

I run Linux but the WebUI was not working for me. The default MTU for my NIC was 1500. After running ‘ifconfig eth0 mtu 900’ to reduce the MTU, the update panel worked!

Please add it to some sort of documentation, that reducing MTU makes the panel working.

Also, could you please aid me with instruction how to restore NOR flash? I suppose I need dd and write to some /dev/mtd* devices the right parts of the image (kernel, initramfs etc).

1 Like

The lower MTU the slower it gets and then it works. I retry multiple times and 1 in 10 tries failed with MTU 900, it its 10 in 10 fails in MTU 1500. I’ve also tried ot set the port to 10 Mbps but that did not do a thing. So really, absurd, small MTU allows the panel (upload) to work. Maybe some of you can debug it more…

@is9aes10 Thanks for this. We will investigate the MTU issue.

When will someone fix all the dead links in these help fora, e.g. go to this link to fix the problem, link is dead, then read some more, then repeat,click here to see how to do it - link is dead

fixed the link. please try.

Hei there,

I have the same problem (AR300M16) it can’t reach WEBUI (192.168.1.1 via LAN )

I tried to flash it but I got blocked ! reset+power+lan on WIN/LINUX/MAC but no page loaded at 192.168.1.1 via LAN
Any suggestion ?

Thanks guru

Why you see 192.168.1.1? Isn’t it 192.168.8.1?

It sounds like he’s trying to access the uboot webfailsafe, which is at .1.1 instead of .8.1

Yes, exactly
I was uploading the new firmware but something went wrong .

GL actually is in recovery mode.

Nope, I can’t see the correct ip, because I think is bricked !

I should reflash the firmware but I can’t reach the Webfailsafe at 192.168.1.1

What I should do ?

Sounds like you might need serial… Do you see one of the lights blink 5 times if you power on while holding reset?

Can you ping it?

Do you see any traffic if you fire up Wireshark on an Ethernet interface connected directly to the unit’s LAN port? (I’ve seen that in some cases, the unit comes up requesting a DHCP lease but if given one, does not answer requests on ANY port. It seems to happen in the dreaded “not marked as tested” failure mode which I think can only be recovered from using seria.

Oh Thanks in advance @Entropy512 .

So basically when I put the Gl in safebootmode as a guide below

https://docs.gl-inet.com/en/2/troubleshooting/debrick/

I’m stopped ad point 5!

After that o try to ping it but it doesn’t recognize nothing …

Any solution or guide ?

Can you describe how the LEDs flash in step 3 and 4?

I have seen at least two cases where the device wound up “bricked” in such a way that it would, instead of coming up with static IP, would be requesting a DHCP lease. Even if a DHCP server provided a lease, it would only respond to pings at the provided IP and not offer ANY other connectivity.

If you look around support threads for the AR300M, it can wind up in a “not marked as tested” state. I don’t know how to identify if you’re in this state without UART serial, other than if you see behavior like what is described above. In my case I needed the UART serial.

Confirmed lowering MTU to 900 worked for me as well. But it took several tries on Linux Mint 19 on Firefox.