Flint 2 (GL-MT6000 ) - bug reports - collective thread

I'm starting to get a bit mistrustful about this router...
All the firmware I have tried is either immediately or after a few days unstable.
The 4.5.8 stable version I had abandoned due to GUI and WiFi instability
Installed the 4.6.0-op24, with which I was satisfied but then I discovered continuous disconnections of the 5Ghz WiFi network which prevented it from being used for example for gaming sessions with the Xbox Game Pass.
So, I switched to Beta 4.6.2 'Release Candidate' but I've already had to restart the router twice because, after some time, it's impossible to access the GUI and the connection is very slow and with high pings.
All firmware installed always deleting all configurations and redoing them each time...
I don't know, by now I'm almost on the way to changing routers and I'd be sorry because some functions are really useful and convenient to use, but the instability of the firmware is cancelling out the positives.

3 Likes

Hey everyone,

I'm facing a peculiar networking issue and could use some advice.

Here's my setup:

  • Ethernet 1: Connected to my ISP modem/router. This is configured via DHCP and DMZ from the ISP side, and everything works fine.
  • Ethernet 2: This is used for my LAN.

The problem arises when I boot up my computer, which is connected to Ethernet 2 and equipped with a 2.5GBe interface. Upon boot, all network interfaces on my router (both wired and wireless, including Ethernet 2) stop functioning. From my computer's perspective, it seems to be negotiating a DHCP status, and the router's light blinks blue. To regain normal functionality, I have to disable and then re-enable my network adapter in Windows. After doing this, I receive an IP address and everything works as expected.

I've tried the following:

  • Disabling all services (ZeroTier, Adguard, DDNS, GoodCloud)
  • Performing a fresh install
  • Trying different versions of the router Preformatted textsoftware

Unfortunately, these steps haven't resolved the issue. I suspect there might be an incompatibility between my GL-MT6000 router and the onboard network adapter in my computer, which uses a Marvell AQtion AQN-107 chipset with drivers version 3.1.8. I've tested this on firmware version 4.5.8 and also tried version 4.6.2, but the problem persists.

Any insights or suggestions would be greatly appreciated!

Have you tried suggestions here?
https://www.reddit.com/r/gigabyte/comments/12otamj/ethernet_internet_connection_drops_with_marvell/

1 Like

How are you accessing the gui?

Gui and WiFi has been stable for me on all firmwares I've tried including the release candidate.

I've not seen your configuration file problem either.

Via http://192.168.8.1/#/login
The LUCI interface, on the other hand, always works correctly

Sorry it's my bad English :slight_smile: I meant that I always installed new firmware by deleting existing configurations

Will try and report back.

Just tried. Still i get the same error. Issue persists. Developers should look into it.

Can you disable the DMZ? Not secure and not necessary in for the case.

The Ethernet 2 is used as LAN right?

Seems your computer is trying to be a dhcp server in this case. We have another case which is quest2 VR which does ipv6 dhcp server and confuses the network.

1 Like

Safe to upgrade from 4.5.8 to 4.6.2 and keep the settings, or is it recommended to start fresh?

1 Like

Howdy!

I just updated from 4.5.8 to 4.6.2
Looks like everything is working fine but I encountered a quirk.
I've described it in detail in this post.

Thanks!

Yeah. Seted up DMZ just to make sure nothing else interupted the Flint 2.

Yes indeed, Ethernet 2 is used as LAN.

I just disabled ipv6 from the adapter options in windows. Now lets wait and see.

Thanks for the recommendation!

1 Like

Word of advice, big version jumps and change of kernel it's always better to do a clean install, the router works better 95% of the time that way.... :call_me_hand:

1 Like

Have you tried to disable the 'Flow Control in Device Manager' and 'Energy Efficient Ethernet' for the Marvell?

Tried to no positive effect.

But i think that my problem was fixed when i disabled ipv6 from windows. We wait & see.

Answer from gl-inet regarding OP24 in another thread: