GL-MiFi or MUDI with Visible

I must be doing something wrong, but I cannot get any of my devices to work with Visible.

The SIM card works well in any phone that I try it in and also works in a Netgear Nighthawk M1 after I use the VSBLINTERNET APN.

In all of my GL-iNet devices, I just get “SIM card not registered” and no connection.

Any ideas?

Just had another case using Visible and got it working.

Pls try using ttyUSB3 as the device, not qmi mode. Pls try.

If you have slow speed, there should be a band problem. Pls get the modem info for further checking.

I switched over to ttyUSB3, but it still displays the sim not registered.

In the cell info, it shows an LTE connection to band 13 with -84dB levels. This tower is very close to me.

What other information would you need me to send to help troubleshoot this?

Are you using The Verizon network? You can try the firmware in the link.
After updating the firmware, ignore the unregistered information and select manual configuration.
Select cdc-wdm0 and fill correct APN, click Apply and wait for the connection.

It’s a little better, in that something is happening, but it’s still not working correctly.

With the new firmware build, when I enter the correct APN, the 3G/4G LED lights up and blinks, the green dot appears in the GUI next to “Verizon”, but it still says “SIM card not registered” and there is no internet connection.

The “Cells Info” page seems broken in this firmware build, so I can’t see the information.

It’s better than the original firmware, but still not working yet.

Did you get your MUDI working with Visible??? I just oredered a MUDI and I have visible. Hopefully when mine arrives it works great out of the box.

Sadly, no I didn’t. I gave up on it and I’m using something else now.

Thanks luochongjun, this firmware has been working for me using Visible on GL-MiFi. Will this be included in a regular firmware release?

Ok, I tried it again tonight and it seems to be working now with the new firmware. The firmware is a bit unpolished, like the “Cell Info” page isn’t formatted right, but at least it’s working with Visible now.

Is there a similar firmware for the X750?

I can only connect to Visible with /dev/ttyUSB3 and I think it’s slower this way.

Asking again about similar firmware for the X750 @luochongjun @alzhao

I got Visible to work once using /ttyUSB3 but haven’t been able to get it working again (X750 with EP06-A)

The modem seems to reboot/restart often (and disappear from the dashboard) with the visible sim.

SIM works fine in my phone and I am using it in the phone now.