GL-MiFi or MUDI with Visible

I must be doing something wrong, but I cannot get any of my devices to work with Visible.

The SIM card works well in any phone that I try it in and also works in a Netgear Nighthawk M1 after I use the VSBLINTERNET APN.

In all of my GL-iNet devices, I just get “SIM card not registered” and no connection.

Any ideas?

Just had another case using Visible and got it working.

Pls try using ttyUSB3 as the device, not qmi mode. Pls try.

If you have slow speed, there should be a band problem. Pls get the modem info for further checking.

I switched over to ttyUSB3, but it still displays the sim not registered.

In the cell info, it shows an LTE connection to band 13 with -84dB levels. This tower is very close to me.

What other information would you need me to send to help troubleshoot this?

Are you using The Verizon network? You can try the firmware in the link.
After updating the firmware, ignore the unregistered information and select manual configuration.
Select cdc-wdm0 and fill correct APN, click Apply and wait for the connection.

It’s a little better, in that something is happening, but it’s still not working correctly.

With the new firmware build, when I enter the correct APN, the 3G/4G LED lights up and blinks, the green dot appears in the GUI next to “Verizon”, but it still says “SIM card not registered” and there is no internet connection.

The “Cells Info” page seems broken in this firmware build, so I can’t see the information.

It’s better than the original firmware, but still not working yet.

Did you get your MUDI working with Visible??? I just oredered a MUDI and I have visible. Hopefully when mine arrives it works great out of the box.

Sadly, no I didn’t. I gave up on it and I’m using something else now.

Thanks luochongjun, this firmware has been working for me using Visible on GL-MiFi. Will this be included in a regular firmware release?

Ok, I tried it again tonight and it seems to be working now with the new firmware. The firmware is a bit unpolished, like the “Cell Info” page isn’t formatted right, but at least it’s working with Visible now.

Is there a similar firmware for the X750?

I can only connect to Visible with /dev/ttyUSB3 and I think it’s slower this way.

Asking again about similar firmware for the X750 @luochongjun @alzhao

I got Visible to work once using /ttyUSB3 but haven’t been able to get it working again (X750 with EP06-A)

The modem seems to reboot/restart often (and disappear from the dashboard) with the visible sim.

SIM works fine in my phone and I am using it in the phone now.

Using GL=E750C4
The link for the firmware did not work but i was able to find it here
https://dl.gl-inet.com/firmware

but i changed to TTYUSB3
LTE/UMTS/GPRS
VSBLINTERNET

and I am still not able to get service

For those having issues with visible. I have gotten it to work consistently with the steps below on firmware 3.100. Please note these are AT commands for the modem, a few people and myself have used this with no issues but I’m not reliable if something happens.

AT+QPRTPARA=3 (modem to its OEM state)

AT+QMBNCFG=“AutoSel”,0 (stop Autoselect config on sim detection)
AT+QMBNCFG=“Deactivate” (disable MBN config)
AT+CFUN=1,1 (reboot the modem)
AT+QCFG=“usbnet”,2 ( MBIM protocol)
AT+QCFG=“nwscanmode”,3,1 ( 4G-LTE only)
AT+CGDCONT=1,“IPV6”,“VSBLINTERNET” (Has to be ipv6 only)

After this the TTL that works for Visible is 64

Also for good measure copy and past this shown below in to custom rules
Tab to the left of custom TTL settings called custom rules.

#start TTL rules
iptables -t mangle -I POSTROUTING -o wwan0 -j TTL --ttl-set 64
#end TTL rules

Note: if you can’t find Custom rules install Luci from the plugin menu and look for Advanced under more settings in the left hand side at the very bottom of the menus.

If you DO not do the ttl visible will limit you to 5mbps.

If the simcard says Sim not registered just restart a couple of times and it should connect.

I got Visible working on MUDI EP06 by using the commands you listed but in a different order.
First I changed to:
TTYUSB3
LTE/UMTS/GPRS
VSBLINTERNET (I typed this where you chose the apn on MUDI)

then

AT+QPRTPARA=3 (modem to its OEM state)
AT+QMBNCFG=“AutoSel”,0
AT+QMBNCFG=“Deactivate”
AT+CFUN=1,1
AT+CGDCONT=1,“IPV6”,“VSBLINTERNET”
AT+QCFG=“usbnet”,2
AT+QCFG=“nwscanmode”,3,1

Reboot Router.

It took a long time and a lot of tries but it has a 20/20 mbs connections now after applying the correct TTL rules. I have read other people have the same issue and have only been able to get 20/20 mbs connections. I tried locking bands with AT+QCFG=“band” but that did not help. I also ran the AT command to change the IMEI because the cap at 20/20 could be because the carrier recognizes the device as a modem. However this also did not help. I guess I should not complain if I am able to have the connection and speed I have now but if anyone can figure out how to get faster speeds that would be great!

2 Likes

I just received my GL-E750 router today. I’ve tried to follow the directions, but I’m not having luck.

When you do the manual setup to you leave the Proto field set to auto or do you change it to qcm?

Also what USB do you run the AT commands against? I’ve tried 2 and 3 but I receive Error for pretty much ever command except the commands to set the modem to OEM state and the reboot command.

1 Like

Hello @ardiross ,

Are you copy and pasting the commands by any chance? You have to manually type them in… The commands are run at 2

First I changed these settings manually in the admin page of the router:
TTYUSB3
LTE/UMTS/GPRS
VSBLINTERNET (I typed this where you chose the apn on MUDI)

then

AT+QPRTPARA=3
AT+QMBNCFG=“AutoSel”,0
AT+QMBNCFG=“Deactivate”
AT+CFUN=1,1

After running AT+CFUN=1,1 the modem will reset so return to the router homepage and wait then enter the following commands:

AT+CGDCONT=1,“IPV6”,“VSBLINTERNET”
AT+QCFG=“usbnet”,2
AT+QCFG=“nwscanmode”,3,1

Then reboot Router.

I recently had to downgrade my router back to 3.100 because after I updated to 3.105 it began to act erratically and would drop both cellular and wifi connections. After the downgrade, my router would not connect even after I ran the above commands. So I ran these commands again:

AT+QMBNCFG=“AutoSel”,0
AT+QMBNCFG=“Deactivate”
AT+CFUN=1,1

and eventually after a few tries and letting it sit for a few minutes at time connected!

I downgraded my firmware back to 3.100. Then ran the commands again and was able to get them to all run successfully. I found that when you copy and past the commands it’s the quotes that makes them fail.

I’m still receiving SIM card not registered though. I also noticed that I only have the four TTYUSB devices. I’m missing the default one. I don’t know if that has to do with anything or not.