Use a LAN port as additional WAN (WAN2)? Possible?

I have an MT1300 and AXT1800. Both devices have 1 WAN port and 2 LAN ports. I have a scenario where I would prefer to use one of the two LAN ports as a second WAN (WAN2).

Is this possible?

My scenario is that I have a Cable modem and DSL modem and would like two hardwired connections to both from the GL-iNET device. Currently I would have to use one hardwired connection and a wireless connection to get a multi-WAN failover scenario to work.

:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

I do not work for and I do not have formal association with GL.iNet

2 Likes

I’m familiar with using VLANs in OpenWRT (tagged/VID and untagged/PVID), and depending on the type of device involved it can become very complex.

Since this is a feature that requires advanced knowledge to implement then I’d like to make a feature request to be able to change a LAN port to a WAN2 port. It’s extremely easy to go the other way - it’s just a button-click on the web interface to change the WAN port into an additional LAN port. But it seems that enough folks would like to use a LAN port as a WAN2 port that a one-click button to enable the reverse would be desirable.

Thanks

6 Likes

for those who are looking for a solution. this idea works on both 3.x and 4.x firmware. You can do this in LUCI:

  1. In Network - Interfaces, in tab Devices tap edit to your br-lan and in Bridge ports uncheck the port that you want to use for wan2
  2. In Network - Interfaces, in tab Interfaces tap Add new interface and name it as wan2, choose DHCP Client option and in Devices choose that interface that you free up on Step 1

Now you have 2 wan: wan default and a new one wan2. But, to make it work like you wish, you’ll need to configure mwan3:

  1. Install “luci-app-mwan3” in Softwsre and reboot
  2. Go to Network - mwan3 Manager (name may vary), tab Intefaces and add new one wan2 and in Tracking hostname or IP address put 1.1.1.1 and tap “+”, Save
  3. Then in tab Member and add new one wan2_only, where choose wan2 as an Interface, Save
  4. In tab Policy edit default_policy and add way2, Save and reboot

Now, you have wan and wan2, that both of them are working and you can check their status in Status - mwan3 Manager (name may vary).

Finally you want to choose the priority for the interfaces. For this you need to change their metrcis:

  1. Go to Network - Interfaces and edit wan and in tab Advenced Settings put Use gateway metric to 10
    2 . Go to Network - Interfaces and edit wan2 and in tab Advenced Settings put Use gateway metric to 20, reboot

So, now, wan is your main internet, and if it will go down, wan2 will start to work.

1 Like

This is very helpful. I have a Brume and found a couple things to note:

  1. Wherever you say “mwan3 Manager” in the menus, my device says “Load Balancing”.
  2. After following the instructions the interface was up, but my devices could not connect to internet. I found that you also need to add wan2 to the Network - Firewall - General Settings - Zones - wan. Go to Covered networks and add.

Now everything works fine. Note that wan2 does not show up in the GL-Net Admin Panel GUI. Have to use Luci to see it in operation.