Spitz AX GL-X3000 will not connect to Verizon

UPDATE BELOW - 99% THERE WITH A FIX!!!

Hello,
I have a new Spitz AX and it will not connect to Verizon.
I have my iPad IMEI in the router.
The SIM card works in the iPad.
On the router I keep getting a message that the SIM card is not registered.
Verizon says everything is good on their end and they see no issues.
The router will occasionally connect and say Verizon Wireless for a few seconds but then it is gone.
I have manually set the APN. I have tried the Verizon profile. I have switched to SIM2 and back to SIM1.
I have tried the SIM in slot 2.
I have reset the router firmware
I have reset the modem with AT+QPRTPARA=3
I am on firmware 0406release1 dated 01/23/2024

I am open to any help anyone can provide.
Thanks,
Randall

Please search the forum I recall people were able to successfully connect to Verizon after flagging the modem module.

Some progress. Downgraded to release50402.
Now I get connected, but still a SIM is not registered message. Also, while connected, I get a message stating the interface is connected, but the internet can’t be accessed.

More progress. I am able to connect but I have to lock a tower manually. If a tower isn’t locked it doesn’t work.
That makes me think this will be useless in motion in an RV unless I find a way around this issue.

Try to set the modem preferences of 5G to selective bands used by Verizon. Check out the AT commands manual at the middle of this post:

I will look into this.
Doing more troubleshooting, if I lock some of the available towers, it will not connect.
Seems everything should work better than this. I wonder if an older firmware ever worked better.

Alright!
Really getting somewhere now.
Ran AT+QMBNCFG=“list”
Saw in that listing that there were only like 5 entries and nothing for Verizon.
I am assuming this is the reason random people have issues on AT&T, T-Mobile and others.
I followed the instructions referenced in this link Great find by another user
Upgraded the modem, and many, many more providers are listed when the list command was run.
The router now automatically connects and gets many towers, including 5G towers in the list if I look to lock a tower.
No more “SIM card not registered” message!
The router boots and will establish a connection on its own.
My account on Verizon’s site shows the IMEI of the iPad as I would expect & is tracking data usage.
The only issue I have now is it seems to always do LTE and if I force the 5G tower by locking, it drops connection and I do get the messages about the sim not being registered and such. It also will not make a connection. Unlock from the 5G tower and all is well again.
I verified the iPad IMEI i am using shows 5G provisioning.
I will continue to troubleshoot, but I think the modem upgrade will fix many users issues.
I am sure I will get 5G working with more time…